Menu
Reply
  • 6
  • 0
  • 1
Torivic
Tuning in
625 Views
Message 1 of 7
Flag for a moderator

Help! iPhone 7 not working with 4G although all settings correct!

Any ideas please?  I upgraded my SIM only plan to 4G, inserted it into my old Samsung in the store and all was working fine.  I then inserted the SIM into my new iPhone 7 four days later but can't get 4G, it keeps reverting to 3G and has done so for the last few days.  I have changed the phone settings to LTE as instructed by Virgin, but it makes no difference.  I can get 4G using the iphone with a SIM card from a different provider, so its not my phone. I am in an area of excellent 4g signal according to Virgin and the fact the SIM works here in a different phone.  So why wont 4G work with iPhone?  Virgin haven't been exactly helpful when I call, so would appreciate it if someone has any thoughts or a Virgin Advisor sees this.  

0 Kudos
Reply
  • 98
  • 3
  • 7
mikefraser
Dialled in
611 Views
Message 2 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

 


Torivic wrote:

Any ideas please?  I upgraded my SIM only plan to 4G, inserted it into my old Samsung in the store and all was working fine.  I then inserted the SIM into my new iPhone 7 four days later but can't get 4G, it keeps reverting to 3G and has done so for the last few days.  I have changed the phone settings to LTE as instructed by Virgin, but it makes no difference.  I can get 4G using the iphone with a SIM card from a different provider, so its not my phone. I am in an area of excellent 4g signal according to Virgin and the fact the SIM works here in a different phone.  So why wont 4G work with iPhone?  Virgin haven't been exactly helpful when I call, so would appreciate it if someone has any thoughts or a Virgin Advisor sees this.  



When you upgrade your account from 3G to 4G, you won't get the latter until your next refresh date. Hope that helps?

0 Kudos
Reply
  • 6
  • 0
  • 1
Torivic
Tuning in
586 Views
Message 3 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

Thanks Mike, having read through these forums I had wondered about that.  But surely if that is the case, I wouldn't have had 4G using my new Virgin SIM card for a few days on my old phone, before my new phone arrived and I swapped it over?  It just the iPhone it doesn't appear to be working on.  I guess I shall hold off for a couple more weeks then and see if it right's itself at refresh time!  Thank you very much for your help.

0 Kudos
Reply
  • 98
  • 3
  • 7
mikefraser
Dialled in
572 Views
Message 4 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

Ooer! Mind you, nothing surprises me about Virgin Mobile these days. That sounds like a glitch, because it's certainly the case that the change won't take effect until your next refresh (and sometimes not even then!!!). Hopefully it'll sort itself out ok; I'm in the same position, albeit I'm an android user, so am anxiously waiting for the refresh. Good luck!

0 Kudos
Reply
  • 6
  • 0
  • 1
Torivic
Tuning in
559 Views
Message 5 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

Thanks Mike, you too! Good luck!

0 Kudos
Reply
  • 98
  • 3
  • 7
mikefraser
Dialled in
493 Views
Message 6 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

Just an update on my situation: today was refresh day, and I got the usual text message saying my account had been refreshed, followed by a further text saying the 4G had been enabled. And it had!!! And, much to my surprise, they'd rolled over the unused data from my 3G account to the new 4G one, having rounded it up from 288 mb remaining to 300mb. Result. So far, the 4G has been rock solid and is clearly much faster. Hope yours either goes OK or has already worked!

0 Kudos
Reply
  • 6
  • 0
  • 1
Torivic
Tuning in
489 Views
Message 7 of 7
Flag for a moderator

Re: Help! iPhone 7 not working with 4G although all settings correct!

Hi Mike, glad to hear you are up and running!  Mine seems to have resolved itself over the last few days too.  I haven't had the usual text message or any notification from Virgin, but 4G suddenly arrived and the data refreshed, so fingers crossed it has all miraculously sorted itself out now!  Many thanks for your assistance and responding to my original plea for help!!