Menu
Reply
  • 13
  • 0
  • 2
wozza1000
On our wavelength
259 Views
Message 1 of 7
Flag for a moderator

H signal not working on my new phone

Hi

 

I'm starting a new thread, because not getting any help.

I have a brand new Galaxy S5 Neo the APN settings are correct.

When I have the H symbol on my screen, I have no internet access and cannot send sms'?

If I have H+ on the screen, everything works fine.

If I have E on the screen, everything works fine (but slower obviously).

If I turn my Data signal off, I can send sms'.

I need advice as to why, when I'm connected with a H data signal (which is better than 3G) I get no internet, and why can't I send sms', when sms' don't require a data signal? This  is really annoying as 90% of the time I am connected to H. Is my phone faulty?

I've tried restart, remove battery, remove sim and all that stuff, and I've deleted, restored and tried different APN settings with no luck.

Any help please?

0 Kudos
Reply
  • 1.87K
  • 174
  • 338
J0hn
Super solver
210 Views
Message 2 of 7
Flag for a moderator

Re: H signal not working on my new phone

It sounds like a setting is out somewhere. A factory data reset should resolve it.

save all you photos and music off the phone and use gmail to back up the rest of your stuff, should take you no more than 10 minutes to resolve this

0 Kudos
Reply
  • 13
  • 0
  • 2
wozza1000
On our wavelength
197 Views
Message 3 of 7
Flag for a moderator

Re: H signal not working on my new phone

Thanks

But I've tried this, and virgin & Samsung have both re-flashed the phones firmware. But the problem remains.

0 Kudos
Reply
  • 1.87K
  • 174
  • 338
J0hn
Super solver
187 Views
Message 4 of 7
Flag for a moderator

Re: H signal not working on my new phone

Sadly I can't help you, you'll need to put yourself in the ands of 789 or 0345 6000 789 for help, I expect it to be difficult to resolve, do other virgin phones have the Sami issue in you area?

0 Kudos
Reply
  • 13
  • 0
  • 2
wozza1000
On our wavelength
179 Views
Message 5 of 7
Flag for a moderator

Re: H signal not working on my new phone

Thanks anyway. I don't know anyone else on virgin mobile... I'm the only mug that's stuck with them. Note to self "there's a reason why virgin's cheaper... because they're ****".

I've heard of a few people on here & other forums with the same problem. I really think it's a compatibility issue between Samsung's firmware and Virgins systems. But you try explaining that to virgin, that's if you can get hold of anyone who understands English (if you know what I mean). Sadly this forum seems useless as well, as it seems most people have given up on it, because there's no one here from Virgin to help!

I'm at the point now, where I'm ready to send the phone back, cancel my direct debit & switch to Vodafone. My son is with them and gets 4G everywhere, while I'm waving my phone around in the air, in the vain hope that I may get lucky and get an internet connection!!!

 

 

[MOD EDIT: Inappropriate language removed, please review the Forum Guidelines]

0 Kudos
Reply
  • 6.85K
  • 217
  • 511
Forum Team
Forum Team
152 Views
Message 6 of 7
Flag for a moderator

Re: H signal not working on my new phone

Hi wozza1000,

I'm really sorry that you have been experiencing problems with your mobile internet connection for so long. Apologies as well for the delay in getting back to you.

I'd like to look into this for you, but I'll need to take more details first.

I'll send you a private message requesting further details. Just check the purple envelope at the top right of this page.

 

 


Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos
Reply
  • 13
  • 0
  • 2
wozza1000
On our wavelength
139 Views
Message 7 of 7
Flag for a moderator

Re: H signal not working on my new phone

Final Update...

My phone has just been returned after being "fixed" for the third time.... and as predicted, it still doesn't work!!! That's me done with Virgin, sending the phone back first thing Monday, I've cancelled my direct debit, and picked up a brand new shiny phone from Vodafone yesterday... and guess what... the signal works brilliant.

Really have had it with virgin and their none existent customer service, I'm severing all ties with them. I have just switched to Sky for my TV & broadband! Its a shame a once good company, has completely gone to the dogs!

Goodbye Virgin!!!!!!!!!

0 Kudos
Reply