Menu
Reply
  • 2
  • 0
  • 0
jallenbah
Joining in
1,274 Views
Message 1 of 5
Flag for a moderator

Data connection not working but showing H+ symbol in Bournemouth

I live in Ringwood but work in Bournemouth. In Ringwood, my data connection works absolutely fine 100% of the time. In Bournemouth, my signal strength is great. My phone always shows the H+ symbol at the top (it's a galaxy s4 mini, I'm on a sim only plan with unlimited data).

 

BUT - the connection only works about 10% of the time when I am at work in Bournemouth, even though it always shows H+. I can send and receive texts and calls, but the data connection doesn't work 90% of the time. I cannot load any pages (it hangs forever rather than shows a no connection error) in the browser or use any apps that require data.

 

This is a very big problem for me. I chose an unlimited data plan because I need to use a lot of data when I'm at work, so having no data connection at all 90% of the time is not workable. If I can't get this resolved I'm going to have to switch provider.

 

What can be done to fix this?

 

What I've Tried

  • Turn off and on mobile data - doesn't fix it
  • Turn off and on airplane mode - doesn't fix it
  • Restart phone - doesn't fix it
0 Kudos
  • 4.44K
  • 139
  • 333
Moderator
Moderator
1,205 Views
Message 2 of 5
Flag for a moderator

Re: Data connection not working but showing H+ symbol in Bournemouth

Hi jailenbath,

 

Welcome to the communitySmiley Happy

 

Sorry to hear your experiencing data connection issues.

 

You can use our coverage checker here to check the coverage in the different areas that you go to.

 

You could try these following steps.

 

Turn your phone off and then back on again.

 

Go into your phone settings and select a network manually.

 

Try removing your phone’s battery, while it’s still switched on

 

Let us know how it goes.

 

Many thanks

 

 

 

 

 

 

 

 

 

 

Stephen_B
Community Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
  • 885
  • 35
  • 476
HughJarsse
Well-informed
1,190 Views
Message 3 of 5
Flag for a moderator

Re: Data connection not working but showing H+ symbol in Bournemouth

Commiserations my friend, I live and work in Bournemouth and regularly suffered the same problem..

Blackberry Z10, showed H+, BB symbol, 5/6 bars, yet NO mobile internet despite the strong signal. (signal checker shows very good/excellent signal for this area)

Been through all this with Mat_H, removal of battery, resetting, changing to manual selection, non of them fixed it.

Mine was resolved (partly) by removing the SIM, and then replacing after 10 minutes. Now better connectivity, but less signal strength!!

Might just need a new SIM, as this appears to solve a lot of the problems, God only knows why??

There was a problem with EE doing work on local transmitters, affecting the signal, according to Mat_H not sure if this is still ongoing though.

My old BB8910 works phone on Orange using 3G signal is faster than by Z10 on (supposedly) H+ signal...pages load 25% faster on the 8910 than the Z10.....

 

Work that one out!!

0 Kudos
  • 2
  • 0
  • 0
jallenbah
Joining in
1,176 Views
Message 4 of 5
Flag for a moderator

Re: Data connection not working but showing H+ symbol in Bournemouth

Yeah, I've tried every variation of resetting, taking out the battery and such. I haven't tried removing the SIM so will give that a go when I have problems, but it seems odd that it would make a difference. The coverage listed for Bournemouth shouldn't be an issue at all. Thanks Hugh (just got your name, good one), it's good to know someone has had a similar problem in the same area. Today my connection was completely fine for whatever reason - I haven't changed anything. Could be to do with the EE work you mentioned. Hopefully it will sort itself out, but if it doesn't I'll try and get a new SIM.
0 Kudos
  • 4.89K
  • 216
  • 441
Forum Team
Forum Team
1,154 Views
Message 5 of 5
Flag for a moderator

Re: Data connection not working but showing H+ symbol in Bournemouth

Hi jallenbah,

 

Thanks for keeping us updated.

 

I'm pleased to hear the connection has improved. If you do experience any further issues please give the team a call on 789 from a Virgin Mobile handset or 0345 454 6000 from any other phone.

 

Please let us know how you get on.

 

Thanks


Rich
Forum Team
0 Kudos