Menu
Reply
  • 2
  • 0
  • 0
Opsmerlin22
Joining in
114 Views
Message 1 of 3
Flag for a moderator

TiVo box broken

My bix is broken
Fault logged and was asked to reset box done this several times.
My recordings are pixelated and keep crashing on playback
Menus are taking about 30 seconds to load

Need s new box
Can someone help

Face booked tech support
Tweeted them too
No response
Tags (1)
0 Kudos
Reply
  • 197
  • 9
  • 59
Browser01
Superfast
110 Views
Message 2 of 3
Flag for a moderator

Re: TiVo box broken

You will have to ring customer services on 150 / 151 and jump through a few hoops. If they cant fix it remotely they will arrange an engineers visit for you. Usual wait seems to be two or three days though : ( 

BTW it sounds like your hard drive might have failed... just guessing, good luck  B

0 Kudos
Reply
  • 4.95K
  • 146
  • 282
Forum Team (Retired) BenD_H
Forum Team (Retired)
58 Views
Message 3 of 3
Flag for a moderator

Re: TiVo box broken

Hi Opsmerlin22,

 

Thank you for your post, welcome back.

 

I am sorry to read about the issues on the TV services, I have been into the account and I can see some signal issues on the box that would need ajusting. This would require an engineer to help adjust this and bring this back to a normal operation.


If you can have a little look inside your 'Inbox', you'll see I've sent you a 'Private Message'. You can find this at the top right of the page, purple envelope Smiley Happy


Speak to you soon.

 

Ben

 


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply