Menu
Reply
  • 1
  • 0
  • 0
StevyG
Joining in
116 Views
Message 1 of 2
Flag for a moderator

Slow Tivo, Slow broadband

Recently our Tivo box has been very slow in responding to commands with blank screens and revolving circles showing persistently for as much as 30+ seconds at a time. Clearly this is very frustrating, especially when you're used to a relatively fast response ( I also have a v+ box in another room that responds instantaneously).

I'm not a techy so am not sure if this is relevant but when I go into the  diagnostics section it shows a Signal Strength of 46% which sounds exceptionally low. Oh, and I've rebooted the box.

At the same time I checked my broadband download / upload speeds at off peak times and got an average of 50 / 11 respectively. I am on the Vivid 152 contract so although I have no unrealistic expectations that Virgin might actually provide a service that would match the 152mb/s it is clear that the service I am receiving is way below an acceptable standard.

I have tried to use the LiveChat facility but am continually confronted by the message that all the operators are busy.

Any advice from the forum would be very much appreciated.

0 Kudos
Reply
  • 20.22K
  • 732
  • 1.51K
Forum Team
Forum Team
67 Views
Message 2 of 2
Flag for a moderator

Re: Slow Tivo, Slow broadband

Hi StevyG, 

 

Thanks for your post and welcome to the Community. It's really great having you on board with us Smiley Happy 

 

Apologies to hear about the issues you are having with your TiVo® running slow. This thread here may interest you: Update to our TiVo boxes

 

I can see since posting, you've been booked an engineer to come to the house to investigate a few things. 

 

Let us know how things go and if you need anything else, just pop back. 

 

Thanks,

Kath_F
Forum Team

Tech fan? Have you read our Digital life blog yet? Check it out



0 Kudos
Reply