Menu
Reply
  • 1
  • 0
  • 0
t_y_l_e_r
Joining in
60 Views
Message 1 of 2
Flag for a moderator

Slllloooowww Search and Discover...

Whenever I use some Tivo services, especially things like YouTube, it takes forever to respond and load.

The delay when moving around menu options is so frustrating and this has been going on for ages.

Last time and engineer visited to investigate broad band issues (problems still exist and although our local engineer gave his direct number I tried to contact him but got no response), he said that as we lived in Peterborough, this was one of the places a 'test' update was applied which caused a number of services to slow down but it could not be reversed.

Oh, and there are frequent short gaps when videos eventually load.

This will be the last attempt at getting a half decent service before cancelling as we have already been told Virgin can't reduce our monthly cost any further. We have never had ano acceptable service since switching to Virginia.
0 Kudos
Reply
  • 6.62K
  • 255
  • 379
Forum Team
Forum Team
27 Views
Message 2 of 2
Flag for a moderator

Re: Slllloooowww Search and Discover...

Hello t_y_l_e_r,

 

Thanks for posting and I'm sorry to learn about the problems you've been experiencing.

 

I understand this must be frustrating for you so what I would like to do is to arrange for another engineer to find out why it's still happening.

 

I'll just send you a private message with appointment times which you will find if you click on the purple envelope at the top right of the screen.

 

Kind regards

 

 

 

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply