Menu
Reply
  • 2
  • 0
  • 0
gr123
Joining in
112 Views
Message 1 of 4
Flag for a moderator

Picture quality poor after fibre broadband installed

Hi,

Have had virgin for almost a year and picture quality has always been fine.. a couple of weeks ago we had virgin fibre optic broadband installed and the guy who came to install used the same cable from the box and the wall and split it at the end to feed both the TiVo and the router.

Since then, I've noticed that the picture quality has been really poor - lines across screen, chunks of pixels etc. Something distorts the picture every 5-10 seconds.

I'm assuming it's because its sharing the same cable? Can I get a separate cable running from the wall exclusively for the router? Will that work?

Any help is much appreciated!
0 Kudos
  • 1.63K
  • 165
  • 288
Parrotperson
Super solver
94 Views
Message 2 of 4
Flag for a moderator

Re: Picture quality poor after fibre broadband installed

Suspect that the signal the TiVo gets is wrong now. TiVo is very sensitive to signal variations. Easiest thing is to ring in and ask them to check your signal. 

0 Kudos
  • 2
  • 0
  • 0
gr123
Joining in
90 Views
Message 3 of 4
Flag for a moderator

Re: Picture quality poor after fibre broadband installed

Will do, thank you.
0 Kudos
  • 7.25K
  • 281
  • 547
Forum Team
Forum Team
61 Views
Message 4 of 4
Flag for a moderator

Re: Picture quality poor after fibre broadband installed

Hi gr123,

A warm welcome to the community Smiley Happy

I'm sorry to hear that your TiVo® hasn't been working well since the Broadband was installed.  I have taken a look at your box remotely and I can see an issue with the upstream power level.  

I will arrange for an engineer to call round and correct this for you.  All the details will be in a private I'll send to you now.  (Look for the envelope icon above.

Collette Smiley Happy


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos