Menu
Reply
  • 12
  • 0
  • 0
jdc22
On our wavelength
656 Views
Message 1 of 3
Flag for a moderator

New customer issues

Hi. I joined Virgin Media at the end of August after switching from Sky. I have the 200Mb fibre, TiVo, and a separate V+HD box. Installation went ok although I'm not overly impressed with the huge great green snake of conduit hanging out of my front wall, and I had to let them use my own internal run of coax to get to the back of the house as they said there was no option other than tacking a white cable to my skirting boards which I wasn't happy about. It also took me a while to work out why I couldn't use the iOS app to control TiVo as he never mentioned the box needs to be connected to the router nor did he leave me an Ethernet cable, fortunately I'd asked for the router to be sited close to the TiVo and I have a stash of spare cables.

Getting used to TiVo has been a challenge, why does it have to be so complicated! Far too many button presses and menus to do very simple things, and why are on-demand, catch-up, apps, and "my shows" all different menu items?!

Not sure which forum to post all this in as it covers TV and Broadband but here goes...

Both TV boxes seem very slow/sluggish compared to the Sky HD ones, TiVo in particular really struggles on occasion especially when there is more than one recording taking place and we often get a "service currently unavailable" error when navigating menus. Watching programmes on the iPlayer can be unwatchable as the stream freezes for a few seconds every couple of minutes. Other times however it will just work fine. The same happens on the V+HD box when watching recorded or on-demand content although it only seems to affects the picture, the audio carries on fine. I don't think this is an internet speed issue as a speed test using a laptop with a wired connection to the router shows I'm easily getting ample bandwidth for iPlayer.

The V+HD box also has a really annoying habit of stopping recording before the programme has finished.

The fibre broadband is fantastic when using a wired connection and I almost consistently get the full 200Mb down and 12Mb up. Unfortunately on wireless I've never got anywhere close to that down speed though. I've changed the 5GHz SSID so I can tell which network I'm on, but even sat within a metre away from the router the fastest download speed I can get is around 60Mb. Upload speed is always 12Mb regardless of device or SSID so at least that's consistent!

Any help, support or advice on the above would be gratefully received...

I've now just received a lovely letter telling me my subscription cost is going to increase by £3.50 a month in November, which would have been nice to know when I signed up, (surely these increases are planned months in advance) so in light of this and the issues I'm having, I'm seriously considering going back to Sky but want to feel like I'm at least getting the most out of what I'm paying for before making a final decision.

0 Kudos
Reply

Helpful Answers
  • 1.63K
  • 165
  • 288
Parrotperson
Super solver
1,282 Views
Message 2 of 3
Flag for a moderator
Helpful Answer

Re: New customer issues

Re slowness of TiVo. http://community.virginmedia.com/t5/Virgin-Media-TiVo-service/Slow-TiVo/td-p/3195456

Theres a new box coming soon ish to rival (in theory) sky Q. Lordy knows what it'll cost though

Your TiVo has its own 10mbps connection 

Try on the TiVo  home-help-settings-network-connect to VM. This may help your service unavailable problems but if it doesn't you may have a signal issue for which you'll need to phone in. Can't speak to the BB, you'll need to gon on the BB forum but I'd thought 60mbps wifi is quite good? 

0 Kudos
Reply

All Replies
  • 1.63K
  • 165
  • 288
Parrotperson
Super solver
1,283 Views
Message 2 of 3
Flag for a moderator
Helpful Answer

Re: New customer issues

Re slowness of TiVo. http://community.virginmedia.com/t5/Virgin-Media-TiVo-service/Slow-TiVo/td-p/3195456

Theres a new box coming soon ish to rival (in theory) sky Q. Lordy knows what it'll cost though

Your TiVo has its own 10mbps connection 

Try on the TiVo  home-help-settings-network-connect to VM. This may help your service unavailable problems but if it doesn't you may have a signal issue for which you'll need to phone in. Can't speak to the BB, you'll need to gon on the BB forum but I'd thought 60mbps wifi is quite good? 

0 Kudos
Reply
  • 12
  • 0
  • 0
jdc22
On our wavelength
634 Views
Message 3 of 3
Flag for a moderator

Re: New customer issues

Thanks Parrotperson, will head over to the BB forum. That article about slow TiVo boxes is over a month old so I guess there's no permanent fix?

Agreed 60mbps is good and for web browsing etc I doubt I would notice much if it was higher but it's frustrating that I'm paying for more than double that and the kit should easily be capable of those speeds. I have a 1gbps home network and would like my wifi to be able to play along nicely with it :-)
0 Kudos
Reply