Menu
Reply
  • 3
  • 0
  • 0
Paul_T_75
Joining in
172 Views
Message 1 of 6
Flag for a moderator

New TIVO box won't start up

Hello, Virgin engineer came around more than 2 hours ago to install new wireless router and TIVO box. Switched it all on, said the TIVO box would start up in about 30 minutes.

In common with other posters on here, we're sitting here watching the thing go through continuous cycles of saying it's going to start up, lights flashing on and off but nothing else happening.

Called 150 who told us it can take 2 hours and gave out some nonsense about  needing that long because it "needs to find the IP address".

Why is nothing ever straightforward with Virgin? Why does the fact of us paying Virgin more money and being "upgraded" like this mean we now have no TV for the rest of the weekend at the very least? Does anyone from Virgin even care about your shabby customer service? Why didn't the engineer stay to make sure the box was working?

Anyone? Paul

0 Kudos
Reply
  • 8.29K
  • 394
  • 973
jb66
Alessandro Volta
162 Views
Message 2 of 6
Flag for a moderator

Re: New TIVO box won't start up

If it's stuck in a loop then I doubt it's going to start up
0 Kudos
Reply
  • 3
  • 0
  • 0
Paul_T_75
Joining in
157 Views
Message 3 of 6
Flag for a moderator

Re: New TIVO box won't start up

I kind of guessed that, it's why the stupid response when we called 150 is particularly annoying. Don't know whether to just switch it off or not?
0 Kudos
Reply
  • 8.29K
  • 394
  • 973
jb66
Alessandro Volta
146 Views
Message 4 of 6
Flag for a moderator

Re: New TIVO box won't start up

You have nothing to loose
0 Kudos
Reply
  • 3
  • 0
  • 0
Paul_T_75
Joining in
131 Views
Message 5 of 6
Flag for a moderator

Re: New TIVO box won't start up

We switched box on this morning and it started to boot up but we couldn't get past installation menu. Engineer came and sorted things out and left. Then a supervisor came and inspected work and replaced some wiring as well as advising other half on how it should work.

We came home from work this evening and now its stuck again cycling through Starting Up message and then doing nothing. Another engineer booked for Friday. This is really rubbish service, I have to say.

0 Kudos
Reply
  • 6.74K
  • 271
  • 490
Forum Team
Forum Team
117 Views
Message 6 of 6
Flag for a moderator

Re: New TIVO box won't start up

Hi Paul_T_75,

 

Welcome to the Community!

 

I'm really sorry to hear about the trouble you've had with your TiVo®.

 

Let me know how the appointment goes on Friday and give me a shout if you need anything else.

 

All the best

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply