Ask a Question
Reply
Fresh as a Daisy
ScottMorris
Posts: 4
Registered: ‎26-02-2012

Xbox Live connection - Breaking Bad

Hi all,

 

Short version - Xbox now always fails to connect with MTU errors after working for months. Tried everything I could find. Failed.

 

Longer version - After months of working acceptably, by 50mB Superhub connection has decided that I spend too much time on the Xbox and has refused to connect for the past week or so.

 

It also semed to take issue with Netflix on the iPhone, but that seems to currently be working. Fingers crossed.

 

I don't recall changing anything from the default configuration, everything seemed to be working well enough after installation. After a week I figure this Xbox glitch wasn't a temporary thing so set about all the troubleshooting I could find.

 

I have, in pretty much all combinations, tried: rebooting the router, resetting to factory defaults, disabling all of the filtering/firewall/etc options, renabling them, disbling UPnP, adding the Xbox to the DMZ, with various theoretically acceptable MTU values, swearing heartily at it, setting port forwarding, changing the wireless transmit band, changing the channel used, using a wired connection, sitting in the corner crying, and even connecting it in cable mode.

 

None of this helped, and the last step makes me believe that it's an issue between the Virgin and Microsoft's upstream servers rather than anything that the Superhub wil have any control over.

 

In the time affected it has, twice, very briefly connected to the Xbox service, only to immediately disconnect when asked to do anything with that connection (play games, watch Netflix, etc).

 

I've also noticed a general degredation in the quality of service when using the laptop or iPhone - some sites taking far longer to resolve and connect that they used to, upload speeds dropping off to dial-up speeds, download speeds occassionally tanking, although none of the above happening frequently enough that on their own I would complain about - it would generally return to normal within the usual window of internet disruptions, but at the minute I guess I'm hypersensitive about it.

 

This is in the G20 area, Maryhill Road, but whenever I've checked the status online VM says everything is hunky-dory. 

 

Does anyone out there have any troubleshooting steps I may have missed, before I undertake some percussive maintenance with a ball-peen hammer?

Please use plain text.
One to Watch
icenoodle
Posts: 19
Registered: ‎21-02-2012

Re: Xbox Live connection - Breaking Bad

[ Edited ]

Hi Scott, I can't help you but just wanted to say I'm having exactly the same problems - and also in G20 area! Haven't been able to get on Xbox Live for a week and similarly tried everything, also getting suspiciously slow upload speeds on the web, which I feel has to be connected. I posted about it 4 days ago or so and this makes me wonder if it's a problem in the area - have been in discussion with the technicians on PMs and will point out this thread to them too.

Please use plain text.
One to Watch
eechiwawa
Posts: 11
Registered: ‎23-02-2012

Re: Xbox Live connection - Breaking Bad

I'm in the same area, G20 Maryhill, and this sounds like the same trouble I'm having. iTunes doesn't seem to want to work, various websites decide from time to time they don't want to load, including this one. If I wait long enough, the iTunes store might load, but I'm getting nowhere with iTunes Match. 

Like you, I tried Netflix on the iPhone last night through the wifi and it wouldn't load because it couldn't connect. iTunes and the App Store on my iPhone won't load either.

After reading your post I decided to try the Xbox, and guess what - MTU errors just like you. It just won't connect online.

I've tried all the steps you've taken, many times over the last few days, but no joy. I even tried using the Virgin proxy, webcache.virginmedia.com on port 8080, but had limited success. It's back to not working properly with or without it.

I don't feel as crazy now I know I'm not the only one in this area with similar problems, but it really needs fixing. Something's not been right with it since at least first thing Monday morning.

Please use plain text.
One to Watch
icenoodle
Posts: 19
Registered: ‎21-02-2012

Re: Xbox Live connection - Breaking Bad

Wooft. This is all sounding pretty familiar - also tried to connect to download some podcasts on my iPhone and couldn't get into the iTunes store on that.

 

Out of curiosity, if either of you try www.speedtest.net do you get the "upload" bit hanging on "connecting" for ages and ages and ages (before eventually being really slow)?

Please use plain text.
Fresh as a Daisy
ScottMorris
Posts: 4
Registered: ‎26-02-2012

Re: Xbox Live connection - Breaking Bad

That's exactly what's happening to me too - ping and download are relatively fine (27ms, 36.73Mbps), upload test waits for about a minute then gets a carrier-pigeon like 0.29 Mbps.
Please use plain text.
One to Watch
eechiwawa
Posts: 11
Registered: ‎23-02-2012

Re: Xbox Live connection - Breaking Bad

Similar here too. Ping 43ms, down 21.79, up 0.23.

I don't know how to get this looked at as I've been told on the phone thre is no fault and averything is fine in this area. It clearly isn't!

Please use plain text.
One to Watch
icenoodle
Posts: 19
Registered: ‎21-02-2012

Re: Xbox Live connection - Breaking Bad

Yep, that's exactly it. I've forwarded this thread to the guy dealing with my post - they generally take 4-5 days to reply to initial posts on here but hopefully I'm now in the problems-getting-dealt-with stage, and it sounds like it must be a problem with the whole area.

 

Don't they realise how dangerous it is to keep people in Maryhill from getting their fix...

Please use plain text.
One to Watch
icenoodle
Posts: 19
Registered: ‎21-02-2012

Re: Xbox Live connection - Breaking Bad

Just a thought for the engineers - according to this: http://shop.virginmedia.com/content/dam/allyours/pdf/schedule%2021%2012%2011.pdf

 the Uddingston server is going to see increased upload speeds in Feb 2012, has a problem occured whilst updating causing G20 to go the opposite way? Are we on the Uddingston server? I can't check just now as not at home...

 

 

Please use plain text.
One to Watch
eechiwawa
Posts: 11
Registered: ‎23-02-2012

Re: Xbox Live connection - Breaking Bad

I followed the link on the PDF and it looks like I (and probably we) are on the Broomhill server which says updated for the upload speeds.

What were they getting updated to anyway? Was it from 1.5Mbps to about 5Mbps?

Please use plain text.
One to Watch
icenoodle
Posts: 19
Registered: ‎21-02-2012

Re: Xbox Live connection - Breaking Bad

[ Edited ]

Aah. Cool. I didn't spot the Broomhill server - so probably not the upgrade, but just a general issue. Here's a guy on another board having similar problems, says he's been told they're sending engineers out tomorrow:

http://www.cableforum.co.uk/board/12/33685883-glasgow-g20-upload-network-issues.html

 

Edit: Yeah, I think 1.5 to 5. 

Please use plain text.