Menu
Reply
  • 2
  • 0
  • 0
Markc2
Joining in
136 Views
Message 1 of 5
Flag for a moderator

Device says not registered

I have 2 devices that have stopped being able to watch live tv. It says they are not registered. But both are listed as registered when logged into my account. Do I need to delete and reregister? But I can only do 1 a month.

Thanks
0 Kudos
  • 24
  • 1
  • 4
Kellders
On our wavelength
114 Views
Message 2 of 5
Flag for a moderator

Re: Device says not registered

Usually removing the app and reinstalling can help. However, as you suggest, you may run out of changes to get them put back on. I would speak to someone in broadband faults as they can go through this with you, adding extra changes if necessary to save you waiting until next month. Good luck!

0 Kudos
  • 20.93K
  • 768
  • 1.56K
Forum Team
Forum Team
92 Views
Message 3 of 5
Flag for a moderator

Re: Device says not registered

Hi Markc2,

 

Thanks for your post and welcome to the forums. It's great having a new face getting involved in the Community Smiley Happy

 

If you updated the app or the OS then you would need to re-register your device. It's easy to do though so don't worry. 

 

Using a PC/Laptop go to anywhere.virginmedia.com > My Profile > Device Settings.Remove the device registration by clicking on the Delete button. 

 

Once you've done this, using the device you are trying to re-register, open up the TV Anywhere app and log in. Try to stream Channel 4 and this should then prompt you to register the device. 

 

Follow the prompts on the app and this will register the device for you and streaming will then commence Smiley Happy If you need an extra change to add the second device again, let us know once the first one has been re-registered and we can add a change for you. 

 

Let me know how things go.

Kath_F
Forum Team

Tech fan? Have you read our Digital life blog yet? Check it out



  • 2
  • 0
  • 0
Markc2
Joining in
88 Views
Message 4 of 5
Flag for a moderator

Re: Device says not registered

Thanks,

Can you add on the extra device change. I have deleted the previous two and re-registered one of them and it works fine.

0 Kudos
  • 7.14K
  • 231
  • 523
Forum Team
Forum Team
62 Views
Message 5 of 5
Flag for a moderator

Re: Device says not registered

Hi Markc2,

 

Thanks for getting back to us--I apologise for the delay in responding to your post. I'm glad to hear that you have been able to get TV Anywhere working on one of your devices.

 

I have now added another device change onto your account as requested.

 

Please let us know if you have any further problems with this.

 

Kind regards,


Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos