Menu
Reply
  • 6
  • 0
  • 0
MrCurly
Joining in
71 Views
Message 1 of 4
Flag for a moderator

Device Registrarion issues again

Hi there

i am having trouble with device registration again. I removed one device this morning in order to add another on Sky sports. Having confirmed the slot was clear, I logged on to the Sky Sports app with the new device. The app kept telling me 'this device is not registered' so I added the name manually to the device registration only to be now told "you have used up both of your device registrations please contact your provider" - what am I doing wrong as every time I try to change devices I end up getting it wrong?

Many thanks

Paul

0 Kudos
Reply
  • 20.94K
  • 769
  • 1.56K
Forum Team
Forum Team
44 Views
Message 2 of 4
Flag for a moderator

Re: Device Registrarion issues again

Hi MrCurly,

 

Thanks for your post and welcome to the forums. It's lovely having a new face on board with us Smiley Happy

 

Apologies to hear you've been having an issue using the Sky Sports app. 

 

> You can manage the devices you have registered for use with the Sky platform by going to anywhere.virginmedia.com > My Profile > Sky Movies & Sky Sports. 

 

> Remove the current registration by clicking on the Delete button.

 

> Once you've done this, using the device you are trying to re-register, open up the Sky Movies or Sky Sports app and select a channel to stream. This will register the device automatically Smiley Happy

 

Come back and let me know how things go. 

 

Thanks,

Kath_F
Forum Team

Tech fan? Have you read our Digital life blog yet? Check it out



0 Kudos
Reply
  • 6
  • 0
  • 0
MrCurly
Joining in
40 Views
Message 3 of 4
Flag for a moderator

Re: Device Registrarion issues again

Hi there Kath

Many thanks for the advice, I have followed your instructions and it worked fine.

i think I keep adding my device name manually (rather than letting the app do it) then it locks me out. 

 

Thanks again,

Paul

 

 

 

 

0 Kudos
Reply
  • 20.94K
  • 769
  • 1.56K
Forum Team
Forum Team
24 Views
Message 4 of 4
Flag for a moderator

Re: Device Registrarion issues again

Hi Paul, 

 

Thanks for coming back and letting us know things are resolved now. 

 

If you have any further issues you know where to find me. 

 

In the meantime, don't be a stranger around the Community! Feel free to browse through the Boards and jump into a thread if you have any advice or tips that may be of use to others.

 

Take care. 

Kath_F
Forum Team

Tech fan? Have you read our Digital life blog yet? Check it out



0 Kudos
Reply