Menu
Reply
  • 3
  • 0
  • 0
AngryAnteater
Joining in
1,543 Views
Message 1 of 10
Flag for a moderator

Websafe not working for all devices

Hi there

I just realised that websafe does not work on my laptop. Phone (Android) and iPad yes, laptop (running on Windows 10) no. Is there anything I can do to rectify this? I'm only moderately tech savvy - might need pointers where to access settings as well as which settings.

Thanks a lot.

0 Kudos
Reply
  • 95
  • 1
  • 16
barmyarmy66
Up to speed
1,531 Views
Message 2 of 10
Flag for a moderator

Re: Websafe not working for all devices

When you say not working, can you clarify?

I would login via said windows 10 box and check that the settings are on in your account, sounds obvious but worth checking.

Once inside, also check what your block settings are (categories, websites etc,)

I would then add a website (website tab below big green buttons) and then try and access it via Windows.

Shout if that works or if we need to try something else.

I use W10 and the settings etc work across the board.

0 Kudos
Reply
  • 1.42K
  • 154
  • 457
Superuser
Superuser
1,521 Views
Message 3 of 10
Flag for a moderator

Re: Websafe not working for all devices

FYIHow to use Web Safe

As suggested by barmyarmy66 block a site or category to confirm Web Safe is working, for example, under Categories block Games, click Apply, and then in your web browser go to miniclip.com to confirm the online gaming site is blocked with the following banner.
2016-11-19-00.jpeg

 

 

0 Kudos
Reply
  • 3
  • 0
  • 0
AngryAnteater
Joining in
1,515 Views
Message 4 of 10
Flag for a moderator

Re: Websafe not working for all devices

Websafe is 'switched' on and definitely working on other devices connected to the router, but it's not working on the laptop. I've selected the basic childsafe settings that block porn and extreme violence etc.. When browsing on my phone (via wifi, not mobile data) or ipad (doesn't even have a SIM) it will sometimes even block sites that aren't all that risquee, on the laptop it will go straight to pornhub no problem.

To check, I did specifically enter the pornsites I know of into the list of banned websites. To no avail.

0 Kudos
Reply
  • 1.42K
  • 154
  • 457
Superuser
Superuser
1,510 Views
Message 5 of 10
Flag for a moderator

Re: Websafe not working for all devices

From what you have described it sounds as through those device are not using Virgin Media's DNS server. To check whether this is the case try the following on your Windows 10 device:

  1. Open a command prompt
  2. Type the following command:

    nslookup URL

    Where URL is the site not being blocked
  3. Repeat step (2) but this time after the URL enter 8.8.8.8
  4. Repeat step (2) but this time after the URL enter 194.168.4.100

FYI, step (2) queries the default name server for your device, (3) Google's name server, and step(4) Virgin Media's name server 

Can you post back here with:

  • the Server: and Address: details from step (2)
  • Are the lines appearing after Non-authoritative answer: in step (3) and step (4) the same, yes or no?
0 Kudos
Reply
  • 3
  • 0
  • 0
AngryAnteater
Joining in
1,504 Views
Message 6 of 10
Flag for a moderator

Re: Websafe not working for all devices

command prompt.PNG

Yup, the non-authoritative answer messages were the same. Address details see pic.

Thank you!

0 Kudos
Reply
  • 1.42K
  • 154
  • 457
Superuser
Superuser
1,489 Views
Message 7 of 10
Flag for a moderator

Re: Websafe not working for all devices

The results confirmed that device is using Virgin Media's name server. Can you repeat the nslookup command but this time replace url with the address of a website not being blocked as expected; just for step (2) and (3).

 

0 Kudos
Reply
  • 2
  • 0
  • 0
MonkeyD-Chris
Joining in
1,129 Views
Message 8 of 10
Flag for a moderator

Re: Websafe not working for all devices

Issue.jpg

 

I'm having the exact same issue, I'm surprised he never replied back to you, but please see attached as requested. I know it's been almost a year.

0 Kudos
Reply
  • 2
  • 0
  • 0
MonkeyD-Chris
Joining in
1,128 Views
Message 9 of 10
Flag for a moderator

Re: Websafe not working for all devices

But the issue isn't specific websites but the websafe as a whole not doing anything on my laptop but working for all my other devices. I think the issue might be with the connection all other devices are using the 5ghz whilst my laptop is connected via 2ghz wifi frequency. Could this be the case?
0 Kudos
Reply
  • 13.63K
  • 719
  • 4.72K
Superuser
Superuser
1,117 Views
Message 10 of 10
Flag for a moderator

Re: Websafe not working for all devices


MonkeyD-Chris wrote:
But the issue isn't specific websites but the websafe as a whole not doing anything on my laptop but working for all my other devices. I think the issue might be with the connection all other devices are using the 5ghz whilst my laptop is connected via 2ghz wifi frequency. Could this be the case?

No - Looking at your screenshot your laptop has been set to use Google's Public DNS, either by yourself or another family member.

To Correct this do the following

  1. Right click the network icon in the Task Bar and click "Open Network and Sharing Centre"
  2. Click the connection in the Middle Right ("Next to Connections")
  3. A new window will appear showing the network status - click the "Properties" button.
  4. In the next section look for the line that says "Internet Protocol Version 4 (TCP/IPv4)" and double click it.
  5. You'll see a new window appear.  The top section should already be set to "Obtain IP address automatically" so leave it alone.
  6. The bottom section will most likely have the lower radio button clicked and Google's servers added.  Simply select the top button "Obtain DNS server address automatically." instead.
  7. Hit OK on each of the open windows and then finally Close on the Status Window to save all the changes.
  8. Verify that the changes have taken by doing a new nslookup
    PS C:\Users\timdu> nslookup google.com
    Server:  cache1.service.virginmedia.net
    Address:  194.168.4.100
    
    Non-authoritative answer:
    Name:    google.com
    Addresses:  2a00:1450:4009:801::200e
              172.217.23.14

Note the server lines noted in red, they may also read 194.168.8.100 instead, these two are Virgin Medias DNS servers - that these are used is essential for Web Safe to work.

Finally if you didn't change the settings, you need to figure out who did, or at the very least make sure they don't do it again.

Consider setting up an additional standard account for regular use and changing the password on the Administrator account to one that only you know.  From then on all family members use standard accounts, preferably separate ones for each family member, and should anything need installing or changing, you as the administrator will be the only person who can authorise changes.

Tim

PS you don't have to screenshot it, you can actually copy the text from Powershell and CMD in Windows 10 to the clipboard very easily by holding the left mouse button and dragging an outline over the text you want to copy and pressing the Enter key.  The outline will vanish and you can use CTRL+V to paste the text into a reply on here (I usually use the "Insert Code" Icon as it preserves the formatting as above).

 

________________________________________


Only use Helpful answer if your problems been solved.