Menu
Reply
  • 7
  • 0
  • 0
RL24
Joining in
182 Views
Message 1 of 4
Flag for a moderator

Terrible broadband speeds again

I have VIVID, which should be up to 200Mbps.

Get just under 30Mbps if I'm lucky.

Is there any way of fixing this as Virgin in meant to be the fastest provider in my area?

0 Kudos
Reply
  • 9.96K
  • 290
  • 622
Forum Team
Forum Team
133 Views
Message 2 of 4
Flag for a moderator

Re: Terrible broadband speeds again

Hey there RL24,

 

Thanks for posting Smiley Happy

 

Apologies for the slow speeds you're currently getting.

 

Have you been testing the network on a wireless or a hard-wired device? Ideally we would need to see hard-wired results.

 

If you don't have a cable let me know and I'll get one sent out to you.

 

Speak soon,

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
  • 7
  • 0
  • 0
RL24
Joining in
127 Views
Message 3 of 4
Flag for a moderator

Re: Terrible broadband speeds again

Great. Thanks

I have a Chromebook, so will need a USB to Ethernet cable.

0 Kudos
Reply
  • 5.89K
  • 157
  • 412
Forum Team
Forum Team
97 Views
Message 4 of 4
Flag for a moderator

Re: Terrible broadband speeds again

Hi there RL24,

 

Thanks for coming back to us about this.

 

I'd like to take a look at your equipment levels and the state of the network segment.

 

I am currently unable to locate your account and have sent you a private mail so that we can chat about this some more.

 

You can locate my message by clicking on the envelope icon near the top right corner of the Community page.

 

Speak soon,

 

Nat_J


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply