Menu
Reply
  • 3
  • 0
  • 0
Trusha
Joining in
138 Views
Message 1 of 6
Flag for a moderator

Speed problems past 6 months

I am getting low speed and paying for a 59 mbs. This has been ongoing for 6 months and when I called virgin they said that they were upgrading the servers and this would be completed by 30th Nov. I am getting 1 my download and 2 upload. In April I was gettin. 37.78 download and 5 + upload. This is ridiculous service. I try calling and it takes so long to get a response
0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
122 Views
Message 2 of 6
Flag for a moderator

Re: Speed problems past 6 months

Hi there Trusha,

 

Thanks for posting and welcome to the community.

 

My apologies that you are having issues with the broadband speeds.

 

I've managed to locate your account and there appears to be a high peak time traffic fault in your area which is causing slow speeds. Our networks team are investigating the problem and are improving bandwidth and performance to help with this issue. The reference number is F003834674 and has a review date of 26th April 2017.

 

One of my colleagues will be in touch with more information.

Regards

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 3
  • 0
  • 0
Trusha
Joining in
83 Views
Message 3 of 6
Flag for a moderator

Re: Speed problems past 6 months

Hi Sam

This is still an issue and it has been going on for a very long time now.

I have just down a speed test and the results are: download - 7.27 and upload 10

We should be getting about 50mbps download.

Please can you look into this ?

Thanks
Trusha
0 Kudos
Reply
  • 13.02K
  • 372
  • 1.06K
Moderator
Moderator
45 Views
Message 4 of 6
Flag for a moderator

Re: Speed problems past 6 months

Hi Trusha,

I'd like into this further for you but am unable to locate your account or run any diagnostic checks on your service.

If you could please drop me PM with the name on the account and your post code I should be able to locate your details and investigate the slow speed issues for you.

Many thanks

 

Ralph_R
Forum Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 3
  • 0
  • 0
Trusha
Joining in
41 Views
Message 5 of 6
Flag for a moderator

Re: Speed problems past 6 months

Hi there

The postcode is BD13 2BG and the name on the account is ############

Thanks
Trusha

[MOD EDIT: Personal and private information has been removed from this post. Please do not post personal or private information in your public posts. Please review the Forum Guidelines]

0 Kudos
Reply
  • 7.36K
  • 314
  • 523
Forum Team
Forum Team
11 Views
Message 6 of 6
Flag for a moderator

Re: Speed problems past 6 months

Hi Trusha,

 

Thanks for getting back to us!

 

I've run diagnostics on your equipment and you levels are all looking healthy at the moment. There are also no network issues currently affecting your connection.

 

Are you still experiencing slow speeds? If so, are you testing the connection wired or wireless?

 

Speak soon

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply