Menu
Reply
  • 10
  • 0
  • 0
SC120
Joining in
97 Views
Message 1 of 4
Flag for a moderator

Slow Broadband

Disgruntled Customer. 

I currently pay for a connection speed of up to 100mps (I wish). I have a Super Hub 2ac Fitted to the system. Between 16/2-20/2 I have been using a Speedtest as recommend by Virgin. The speeds vary from 'Download' 10.32mps (1722 19/2) - 77.26mps (1328 17/2). The speeds are normally between 40-60mps. The 'Upload' speed is quite constant , 6-7mps. 

I have used the Run Test on the Virgin web site and that only checks up to 34% and fails to complete, although it then says ' ok we didn't find a fault in your equipment.  

Come on Virgin sort this out, please!!!

0 Kudos
Reply
  • 8.35K
  • 362
  • 589
Forum Team
Forum Team
65 Views
Message 2 of 4
Flag for a moderator

Re: Slow Broadband

Hi SC120,

 

Thanks for posting!

 

Sorry to hear you're having trouble with your connection.

 

I've located your account and I can see you've got a technician booked to check this out. Let me know how the appointment goes and give me a shout if you need anything else.

 

All the best! Smiley Very Happy

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
  • 10
  • 0
  • 0
SC120
Joining in
56 Views
Message 3 of 4
Flag for a moderator

Re: Slow Broadband

I wish. It was cancelled by yourselves. You said there was a problem in the network and that you had sorted it. Still not satisfied. The speed is slightly better, 26-54, average, 35. Your staff said it was because a cordless phone was in the room. I wish the engineer was coming to have a look at the set up. 

 

Thanks for for replying anyway

 

Stuart Cooke. 

0 Kudos
Reply
  • 8.35K
  • 362
  • 589
Forum Team
Forum Team
44 Views
Message 4 of 4
Flag for a moderator

Re: Slow Broadband

Hi Stuart,

 

Thanks for getting back to me.

 

I'm really sorry to hear the appointment was cancelled. I can see the details of the network issue and the network team have now resolved it.

 

I'm glad to hear the speed has improved but it's still not enough! I've run a diagnostic on your equipment and I can see an issue with your Upstream Power levels that will need to be adjusted. I've sent you a private message (purple envelope at the top right of your screen) so I can arrange an appointment.

 

Speak soon Smiley Very Happy

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply