Menu
Reply
  • 2
  • 0
  • 0
paul_jen
Joining in
77 Views
Message 1 of 2
Flag for a moderator

Slow Broadband and Tivo Losing Service

Hi, we have just joined Virginmedia coming from Sky and not impressed at all so far.

We are paying for 50MBs but only getting around 20 during the day and getting as low as 6mbs in the evening. We did get 47 mbs on day 2 but since then it has been terrible. I appreciate that traffic will be heavier in the evening and I can cope with 20 mbs  as we were getting this with Sky but at least this was consistent no matter what time of day. Also, the Tivo box also stops playing every now and then stating that the internet connection is too slow. We never had any buffering problems with Sky but the service from Virgin reminds me of the the dial up connection that I had 20 years ago!

Have tried the connection checks via the web site and even received texts with a reference number to say that any issues have been sorted out but to no avail.

The Tivo box is connected directly to the Hub via the Ethernet cable provided and although the connections on on the laptops and PC are normally via WiFi, the connection speed doesn't improve much if connected directly via Ethernet cable.

Only one month into our contract with Virgin Media but can't wait to get back to Sky in November.

Any advice to help improve this horrendous service would be appreciated. 

0 Kudos
Reply

Helpful Answers
  • 7.36K
  • 315
  • 524
Forum Team
Forum Team
73 Views
Message 2 of 2
Flag for a moderator
Helpful Answer

Re: Slow Broadband and Tivo Losing Service

Hi paul_jen,

 

Welcome to the Community!

 

Really sorry to hear you're having trouble with your services, not a great start!

 

I've run a diagnostic on your equipment and I can see an issue with your Downstream Power levels that are likely causing the problems you've described. I've sent you a private message (purple envelope at the top right of your screen) so I can arrange for a technician to sort it out.

 

Look forward to hearing from you! Smiley Very Happy

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply

All Replies
  • 7.36K
  • 315
  • 524
Forum Team
Forum Team
74 Views
Message 2 of 2
Flag for a moderator
Helpful Answer

Re: Slow Broadband and Tivo Losing Service

Hi paul_jen,

 

Welcome to the Community!

 

Really sorry to hear you're having trouble with your services, not a great start!

 

I've run a diagnostic on your equipment and I can see an issue with your Downstream Power levels that are likely causing the problems you've described. I've sent you a private message (purple envelope at the top right of your screen) so I can arrange for a technician to sort it out.

 

Look forward to hearing from you! Smiley Very Happy

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply