Menu
Reply
  • 5
  • 0
  • 0
RJ21
Tuning in
184 Views
Message 1 of 6
Flag for a moderator

Slow Broadband Area 20 (PO1)

 
 

speedof.me speed test just gave me 9MB

speetest.net (which usually gives 53MB) was also below 10MBth

Phone support went through well trodden algorithm and said there was no problem.

Just checked the hub and noticed Downstream Power Level (dBmV) was 12.7-13.1

I think that might be a little on the high side, can anyone confirm?

0 Kudos
Reply
  • 43
  • 2
  • 10
MrBungle
Dialled in
179 Views
Message 2 of 6
Flag for a moderator

Re: Slow Broadband Area 20 (PO1)

Im in area 20 and on upto 50 meg connection and have recently reported slow speeds. this morning after my superhub green light started flashing (loss of connection) i came back 10 minutes later so i speed checked @ 20meg Two days ago it was 11?.

It's very up and down with speed and has been for the last few months with no explanations as to why.

They are supposed to be upping me to 75 for free but its like get the 50 right FIRST and maybe ill believe it!

0 Kudos
Reply
  • 5
  • 0
  • 0
RJ21
Tuning in
143 Views
Message 3 of 6
Flag for a moderator

Re: Slow Broadband Area 20 (PO1)

So five months on and still no fix! Virgin have reduced my bill and told me it might be fixed by September (+Nine months)

Last week at work (via BT) I checked my Virgin email, The Virgin Vivid 200 Ad banner popped up so I put in my post code and guess what..

It's available in my area!!!!

I have just completed a live chat (or bot chat) where "Lily:" Confirmed that Vivid was available in my area and she or bot were very keen to sell me the upgrade.

When I pointed out that I was on a reduced bill because of poor service, I was told the upgrade might fix it!!!

Really!

I mean Really!!

You can downgrade if it doesn't work!!!

Trust in the brand is wearing thin.

0 Kudos
Reply
  • 5
  • 0
  • 0
RJ21
Tuning in
105 Views
Message 4 of 6
Flag for a moderator

Re: Slow Broadband Area 20 (PO1)

15 Months of poor performance!

Any news on Fault ticket F004272403 ?

 

0 Kudos
Reply
  • 10
  • 1
  • 1
AnyonebutVM
Tuning in
95 Views
Message 5 of 6
Flag for a moderator

Re: Slow Broadband Area 20 (PO1)

I've been suffering in Area 20 for over 12 months. When Virgin started quoting how much data I'd used when I complained about the speeds, that was the final straw. My 50mb broadband frequently dropped below 2mbps at peak times. Yes I had 30mbps at 4am and 2pm, but that isn't when I needed it.

Finally switched the BT, so far, so good. Download speed has been consistently 50mbps everyday, regardless of time. Even with copper connections, BT are still out shining Virgin massively in Area 20.

I think you've given them enough of a chance, I know I did. Just wait for the bad attitude when their last ditch team try to tempt you with double speeds for half the price. At the moment I wouldnt pay £5 for their 300mb broadband. Until they invest massively in their infrastructure, i recommended running away as fast as you can. You won't regret it, I certainly haven't.
0 Kudos
Reply
  • 7.33K
  • 307
  • 520
Forum Team
Forum Team
62 Views
Message 6 of 6
Flag for a moderator

Re: Slow Broadband Area 20 (PO1)

Hi RJ21,

 

Thanks for posting!

 

The most recent review date for fault ref.(F004272403) is 13th December 2017.

 

All the best! Smiley Very Happy

 

Josh


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply