Menu
Reply
  • 1
  • 0
  • 0
Jcpcelt
Joining in
91 Views
Message 1 of 2
Flag for a moderator

Ping >15ms regularly causing issues

Hi 

I've been having some issues recently with my latency. I'm hitting pings of 15-18m/s against local virgin servers, whilst my download (70-75mb) and upload (3-4mb) are perfectly adequate. This is causing untold pain in my gaming as the ping to the game servers is then even higher. My download  is also unstable, in graph form you can see regular drop outs. This is using RJ45, but no - not in modem mode, and I need to remain in router mode due to other housemates devices in the home so this isn't an option.

It also tends to be that the wired and wireless pings will be the same at any given time, so it's looking like either the supply is the problem, or the router.

I need <10ms for me to game easily. That little bit of drag in latency annihilates my experience and leaves me frustrated.

There are no issues in my area according to the service status checker, and this occurs typically for 3-4 days at a time. Resetting the router to factory default doesn't help, nor does port forwarding etc and the speedtests are being run with a Macbook wirelessly and wired, an iPad and iPhone wirelessly and a windows laptop wired and wirelessly.

Can anyone gimme a hand please?

0 Kudos
Reply
  • 5.32K
  • 169
  • 353
Moderator
Moderator
64 Views
Message 2 of 2
Flag for a moderator

Re: Ping >15ms regularly causing issues

Hey Jcpcelt,

 

Welcome to the community Smiley Happy

 

I'm sorry to hear that your ping times are negatively impacting upon your gaming experience, that's not what we like to hear Smiley Sad I've tried running some tests but I've been unable to locate your connection details here.

 

I'll send you a PM (purple envelope, top right) so we can get a few more details from you. Drop me a reply when you get chance and I'll get back to you asap.

 

Speak soon Smiley Happy

Kev

The do's and don'ts. Keep the community welcoming for all. Follow the house rules