Menu
Reply
  • 4
  • 0
  • 0
difrt
Joining in
115 Views
Message 1 of 5
Flag for a moderator

Paid for 150Mbps but it hasn't gone above 20Mbps in the last 3 months

My internet speed dropped to less than 20 Mbps for more than 3 months now and I can't get it sorted. I complained in October and messaged someone from Virgin on the forum but I was told they couldn't look into my issue UNLESS I created a new post (which I'm doing now).

I decided then to try and call them only to get stuck twice in the waiting -- one of the times for almost 20 minutes. I kind of gave a up a bit since then because I was really busy trying to keep up with lectures, work and life in general. 

Can someone take a look at my issue now? And also I want back the money I paid for the speed which was not delivered over the last few months. 

0 Kudos
Reply
  • 9.02K
  • 760
  • 1.88K
Superuser
Superuser
96 Views
Message 2 of 5
Flag for a moderator

Re: Paid for 150Mbps but it hasn't gone above 20Mbps in the last 3 months

Is the slow speed all the time or just during evening peak hours?

I would test the speed using a device connected directly to the hub by ethernet cable, during the day and again in the evening.

If you get full speed during the day and poor speed during the evening, then you might have an utlisation issue.

0 Kudos
Reply
  • 5.37K
  • 273
  • 1.18K
Superuser
Superuser
90 Views
Message 3 of 5
Flag for a moderator

Re: Paid for 150Mbps but it hasn't gone above 20Mbps in the last 3 months

If you've been testing wirelessly, you are potentially hitting the cap of your wireless environment/devices.



Follow Griffins questions above.
~~~~~~~~~~~~~~~~~~~~~~~~~
All posts made are personal opinions as I do not work for VirginMedia.
Kudo's a post if you find it useful and want to say thanks
Mark a post as a helpful answer if it answers your question

0 Kudos
Reply
  • 4
  • 0
  • 0
difrt
Joining in
71 Views
Message 4 of 5
Flag for a moderator

Re: Paid for 150Mbps but it hasn't gone above 20Mbps in the last 3 months

There's nothing wrong with my setup and I have noticed horrible speeds constantly -- day, evenings, middle of the night. I have a computer attached directly to the router and it reports the same low speeds. 

Even if my devices were not able to support high speeds on WiFi, you would still expect them to be able to communicate above 20 Mbps. A good indication is that copying things over between devices using WiFi and in my local network is quite fast -- I can copy gigabytes of data across devices in few seconds. So it's definitely nothing to do with WiFi or my setup.

Another good indication this is Virgin's fault is the fact that it started happening without nothing being changed or introduced at my home.

What I think it is: Virgin promised more than it could deliver. There has always been all sorts of issues, I had low speeds before and had o wait months for my area to be upgraded. Then after the upgrade, the speeds were high again, just to drop abruptly in the following months. AFAIK, Virgin never really delivered consistently above 100 Mbps since I am a customer. I shouldn't have to be chasing them to get this fixed.

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
47 Views
Message 5 of 5
Flag for a moderator

Re: Paid for 150Mbps but it hasn't gone above 20Mbps in the last 3 months

Morning difrt,

 

Hope all is well. Thanks for taking the time to post on the community.

 

I am sorry to read that you are experiencing slow broadband speeds.

 

I've taken a look at your connection, the line and hub have come back as fine. However there is a high peak time traffic fault in your area which is causing slow speeds. The reference number is F003357170 and has a review date of 1st February 2017.

 

You mentioned that you get slow speeds at all times of the day, are you able to complete speed tests whilst the Super Hub is in modem mode please? This will eliminate other devices connected.

 

Let me know how you get on

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply