Menu
Reply
  • 8
  • 0
  • 0
kmordaunt
Joining in
130 Views
Message 1 of 4
Flag for a moderator

Nowhere Near 150mbps

Hi,

For a while now I've been concerned about the downstream speed of our broadband connection as although we have upgraded packages multiple times, our speed seems to have been getting worse instead of better and we're now paying more for a service which doesn't seem to be improved at all!

This problem has gotten slowly worse over time and recently, we're lucky to any more than 20mbps down on a very capable 5GHz Wi-Fi signal with incredibly close proximity. Now I know you're going to say that we should instead try a wired connection, which I have done and speeds improve to 30/40mbps through Ookla Speedtests (to a server hosted by Virgin Media, actually), but never have I ever experienced speeds above 40mbps in the past few months. The broadband connection with you guys has been awful ever since our service with NTL transitioned to VM and in fact I never remember our service ever getting better!

Please for the love of all that is holy, fix our broadband so that I can expect STABLE speeds of over 100mbps at least considering the package is 150 fibre.

 

Thanks,

Karen

0 Kudos
Reply
  • 6
  • 0
  • 1
Vinny
Tuning in
110 Views
Message 2 of 4
Flag for a moderator

Re: Nowhere Near 150mbps

I have complete sympathy for you.  I have been upgraded to 200 mbs  but only get around 39 to 49 mbs if I am lucky.   did a speed test with my iPhone and got 30mbs  then another speed test on the iPhone at my sons home as he has Sky and got the same download speed but a slightly slower upload speed    Amazon Prime buffers on my LG smart TV and sometimes I get a message to say the connection is too slow.  Been a cable subscriber since 2000 starting with NTL and have had issues ever since then VM is no exception except the price keeps getting bigger it is the only thing that seems to be accelerating upwards as the download speeds do not!

  • 8
  • 0
  • 0
kmordaunt
Joining in
88 Views
Message 3 of 4
Flag for a moderator

Re: Nowhere Near 150mbps

Yeah,

It sure is irritating when I know for a fact that it's not down to my hardware because I'm running pretty hi-spec stuff.

Furthermore, I know that better service is possible, sure the infrastructure's different out there, but just look at Japanese and South Korean internet speeds! They're stable and incredibly fast even to American servers. Not just abroad either though, here in the UK I have friends on significantly lower packages (paying a lot less) and getting significantly faster broadband speeds (and more stable, because I get constant drop-outs and high-utilization issues here).

It's honestly disgraceful to take over £70 from us each month and deliver a hap-hazard, crappy service!

 

Karen

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
62 Views
Message 4 of 4
Flag for a moderator

Re: Nowhere Near 150mbps

Hi Karen,

 

Thanks for posting on the community. It's nice to have you back here.

 

My apologies that you are experiencing slow broadband speeds.

 

I've managed to locate your account and there is a high peak time traffic fault in your area which is causing slow speeds. Our networks team are investigating the problem and are improving bandwidth and performance to help with this issue. The reference number is F004139154 and with a review date of 7th December.

 

Do you notice these slow speeds at all times of the day or just during peak hours?

Are you able to complete speed tests whilst the Super Hub is in modem mode please? This will eliminate other devices connected.

 

Hope to hear from you soon

Sam

 

 


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply