Menu
Reply
  • 70
  • 0
  • 1
jwintermute
On our wavelength
215 Views
Message 1 of 13
Flag for a moderator

My 'upgrade to 150Mbs' has gone missing ...

Hi all,

For the past few months, when I logged in to my account, there was Usain staring out at me telling me my upgrade to 150Mbs (from 100Mbs) was on its way and would be ready by the end of November.

This week I upgraded my phone package, which involved a new contract, and now Usain's disappeared, and all I see is a message saying "Your speed boost is complete!" - to the 100Mbs I already had.

I phoned support and they said they couldn't see any upgrade due, and that I should try again at the end of the month.

Has anyone had a similar experience? I'm in London SE7

Cheers!

0 Kudos
Reply
  • 2.62K
  • 209
  • 799
Dave_cq
Trouble shooter
206 Views
Message 2 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

I've seen other posts like this and it does seem to be VM's crazy policy ... existing customers get offered the free speed boost but if you change your package and get a new contract you lose it.  Seems totally daft to me.

 

********* SuperHub 2ac - Asus rt-ac68u Router - Vivid 100Mbps **********

Electron
0 Kudos
Reply
  • 70
  • 0
  • 1
jwintermute
On our wavelength
193 Views
Message 3 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...


Dave_cq wrote:

I've seen other posts like this and it does seem to be VM's crazy policy ... existing customers get offered the free speed boost but if you change your package and get a new contract you lose it.  Seems totally daft to me.

 


That's bonkers. I think I will write to them then, as that's just unfair. Especially after when arranging the add-ons, the bloke on the phone told me I'd been with them 16 years and they'd do anything for their long-term customers Smiley Happy

0 Kudos
Reply
  • 2.62K
  • 209
  • 799
Dave_cq
Trouble shooter
191 Views
Message 4 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...


jwintermute wrote:

Dave_cq wrote:

I've seen other posts like this and it does seem to be VM's crazy policy ... existing customers get offered the free speed boost but if you change your package and get a new contract you lose it.  Seems totally daft to me.

 


That's bonkers. I think I will write to them then, as that's just unfair. Especially after when arranging the add-ons, the bloke on the phone told me I'd been with them 16 years and they'd do anything for their long-term customers Smiley Happy


Oh they do ... they make sure that long-term customers pay far more that new customers ... do try to look grateful.   Smiley LOL

 

********* SuperHub 2ac - Asus rt-ac68u Router - Vivid 100Mbps **********

Electron
0 Kudos
Reply
  • 70
  • 0
  • 1
jwintermute
On our wavelength
184 Views
Message 5 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...


Dave_cq wrote:


Oh they do ... they make sure that long-term customers pay far more that new customers ... do try to look grateful.   Smiley LOL

 


Ha! I suppose I should have waited till I'd received the speed boost before upgrading the phone. Just didn't think it would affect it.

0 Kudos
Reply
  • 626
  • 16
  • 64
shawty1984
Fibre optic
177 Views
Message 6 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

The banner has gone for me but we haven't updated our package.
0 Kudos
Reply
  • 5.35K
  • 272
  • 1.18K
Superuser
Superuser
171 Views
Message 7 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

Taking discounts also effects your eligibility for the upgrade.
~~~~~~~~~~~~~~~~~~~~~~~~~
All posts made are personal opinions as I do not work for VirginMedia.
Kudo's a post if you find it useful and want to say thanks
Mark a post as a helpful answer if it answers your question

0 Kudos
Reply
  • 626
  • 16
  • 64
shawty1984
Fibre optic
169 Views
Message 8 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

No changes whatsoever on the account. Seems like they were messing with MyVirginMedia and have screwed things up.
0 Kudos
Reply
  • 12
  • 1
  • 3
tubbychris
On our wavelength
165 Views
Message 9 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

They certainly seemed to have messed up MyVirginMedia, I log in today, and all I get is "Hi Chris" followed by account number and area code....  that's it! No bill overview, no package overview and most certainly no Usain Bolt banner!

Issues just seem to be escalating one on top of the other at the moment.

0 Kudos
Reply
  • 626
  • 16
  • 64
shawty1984
Fibre optic
163 Views
Message 10 of 13
Flag for a moderator

Re: My 'upgrade to 150Mbs' has gone missing ...

Go and look in the upgrade offers. Offering stuff for £200+ a month (extra £70+ per month). Seems like this company can get nothing right.
0 Kudos
Reply