Menu
Reply
  • 1
  • 0
  • 0
yg8888
Joining in
126 Views
Message 1 of 5
Flag for a moderator

Constantly Slow Speeds

Hey, Basically I've been having problems constantly with virgin media about speed issues and the inconsistency with them, I'm currently on a 75mbps package recommended to me for the usage used. So ever since i've been upgraded to this package the internet has been terrible, constantly slow I did a speed test and this is what I got:

The server is a virgin media server in Wolverhampton and i'm currently in stoke.

Is there any way of getting some-what good speeds I wouldn't be bothered if it was 50mbps and 15 ping or so but these speeds are ridiculous.

0 Kudos
Reply
  • 15
  • 1
  • 0
Elston
On our wavelength
110 Views
Message 2 of 5
Flag for a moderator

Re: Constantly Slow Speeds

@yg8888,

I'm with you on that one and it is my intention to cancel my subscription with VM and go with A N Other.

I struggle to understand how VM can expect me to pay for a service , or services, that I am clearly not getting.  B/band speed and telephony have been patchy at best and it was with the goodwill of one the forum agents (kudos Rose_B) that I managed to get an engineer to visit.  It's a strange irony that as the prices go up and up, the quality of service goes down and down.  I wouldn't mind so much if the charges changed in relation to the quality of services but they don't: They stay the same...then increase!

I don't know what else to do.  VM keep espousing utilisation problems but please, give me break!  VM should recognise that their network is simply NOT equipped to handle this kind of demand and 'hold their hands up'.

I'll let you know how I get on.

Elston.

 

0 Kudos
Reply
  • 15
  • 1
  • 0
Elston
On our wavelength
81 Views
Message 3 of 5
Flag for a moderator

Re: Constantly Slow Speeds

@yg8888,

Well, after contacting VM to cancel my contract, they immediately amended my package (removed Sky Sports), increased my broadband to 100Mb, 'threw in' a Superhub 3.0 (SH3) and slashed my subscription by an order! So far, so good.

I have to report since installation, everything's gone OK. Broadband's much improved and SH3 handles multiple devices with little impact on bandwidth, especially wireless. I was hoping to use SH3 in modem mode and use my router to spray the signal but modem mode doesn't work with the current firmware. I check regularly to see when the next firmware update will be but things seem to be on the slow side for now.

That aside, it's another strike for VM! It's not perfect, but things are a damn sight better now than they were a few weeks ago. Keep it up VM.

Elston.
0 Kudos
Reply
  • 12.48K
  • 353
  • 1.45K
Forum Team
Forum Team
61 Views
Message 4 of 5
Flag for a moderator

Re: Constantly Slow Speeds

Hi Elston,

Sorry we didn't reach your posts before now. I'm glad you've managed to get things sorted out to some degree of satisfaction and appreciate you posting that update Smiley Happy Your Hub 3 does have the latest firmware version so using it with your own router, with modem mode enabled, shouldn't be a problem. 

If you do have any further queries or issues please do come back to us for support. But please allow a week or so for us to respond.

All the best Smiley Happy


Jen
Forum Team



0 Kudos
Reply
  • 15
  • 1
  • 0
Elston
On our wavelength
45 Views
Message 5 of 5
Flag for a moderator

Re: Constantly Slow Speeds

@Jen_A,

Will do.  It'll be in a couple of days.

Thanks for the heads up.  I'll get back to you when done.

Cheers.

Elston.

0 Kudos
Reply