Menu
Reply
  • 2
  • 0
  • 0
MikeSim
Joining in
97 Views
Message 1 of 3
Flag for a moderator

Broadband speed has dropped a lot

After some maintenance in my area my internet speeds have dropped significantly. I'm paying for 200mbps and getting less than 50mpbs. I have always gotten at least 100mbps. I contacted the helpline via the phone and was treated to 20 minutes of the most unhelpful nonsense I've ever heard made even worse by the fact that apparently the call centre was experiencing a "bring your dog to work" day as all I could hear was barking in the background. The advisor "advised" me (and I use quotes for that as I question this advice) that my LAN card was not supported. I know this to be nonsense for so many reasons but primarily because it has not been a problem until this month. Unless you've been doing some major upgrades in which a considerate "by the way the work we're doing may result in you requiring new hardware for all your equipment including that brand new expensive laptop you just bought" I sincerely doubt this is the issue.
Suffice to say after wasting my time trying to explain why he was wrong I hung up. My net speed is unusable. I'm not paying the money I am for an internet worse than what I could get via a phone line connection and frankly I don't care very much for incompetant call centres telling me "sucks to be you" either.

 

Is anybody in a position to help? Or should I look elsewhere for my service? Because I am not very happy.

0 Kudos
Reply
  • 1.11K
  • 95
  • 275
vircom
Knows their stuff
70 Views
Message 2 of 3
Flag for a moderator

Re: Broadband speed has dropped a lot

It may take up to about a week for the VM forum team to respond to your post. Hopefully they will be able to test your service and give you a sensible explanation and solution?
0 Kudos
Reply
  • 2
  • 0
  • 0
MikeSim
Joining in
42 Views
Message 3 of 3
Flag for a moderator

Re: Broadband speed has dropped a lot

That's assuming this gets read as it's already been bumped to the second page.

0 Kudos
Reply