Menu
Reply
  • 1
  • 0
  • 0
fake_dante
Joining in
68 Views
Message 1 of 2
Flag for a moderator

Atrocious speed! Took me 10 minutes to create an account here!

Hello everyone,

What is happening to Virgin recently? For the past 4 evenings in a row, my internet speed has become worse than terrible. Here is my speedtest I took today (I do have other speedtest from other days as well) http://www.speedtest.net/my-result/6117116913

I'm contracted for 150Mb/s! I can't load my emails, let alone watch a video of any sort. I am connected through an ethernet cable and there's only 2 devices connected to my broadband which is my computer and my phone. 

For reference, my area is 20, Hapshire

0 Kudos
Reply
  • 10.82K
  • 308
  • 632
Forum Team
Forum Team
37 Views
Message 2 of 2
Flag for a moderator

Re: Atrocious speed! Took me 10 minutes to create an account here!

Hi fake_dante,

 

Welcome to the community and thanks for posting.

 

Sorry to read you are experiencing slow broadband speeds. I know how frustrating this can be.

 

From checking your connection, there is a high peak time traffic fault in your area which is causing slow speeds. The reference number is F004159125 and has a review date of 12th April.

 

I also noticed that the downstream power levels are too high at +18 dBmV and as this can also have an impact on your connection, I would like to arrange an engineer appointment. I've sent you a PM (purple envelope icon, right corner) with some details for you to confirm please.

 

Hope to hear from you soon

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply