Menu
Reply
  • 1
  • 0
  • 0
RuiSamuel
Joining in
95 Views
Message 1 of 4
Flag for a moderator

Area 15 - Terrible download speed!

So... I moved house and signed up to VM with reservations, however the offer was very good and I was informed by people, whom I value their opinions, that VM was much improved over the years and now was now rivalling BT and was a lot more reliable.

How mistaken I was...

After getting the 100mbs connection set up early November, I have never reached download speeds >20mbs. However, my upload is maxing out at 6mbs. Currently, my speed fluctuates between 1mbs and 10mbs, not even seemingly to depend on the time of day!

I have "chatted" to the help multiple times, each time they "changed some settings" and asked I monitor it for a few days. I have done this 3 times and seen no difference.

After the first time, they sent out an "engineer" who tested our equipment and found no fault. He discovered there was a problem in the area (15) to do with upload speeds and said this might fix out problem. It didn't, obviously.

I have no chatted twice more with technicians who suggested sending out a "senior engineer" to address the problem.

I now cannot get through to talk to anyone, online or on the phone, to organise this engineer visit!!

This is atrocious, for a new customer to have not received even half of what they are paying for is ridiculous. I feel sorry for all these people on this forum that this has been going on for months to!

If I could talk to someone, at least if they cannot guarantee that it will be fixed soon I could leave! But alas I can't even speak to anyone! (I am sick to death of the hold music...)

I will not be recommending VM to anyone and will not be back in the future if this is not resolved soon.

0 Kudos
Reply
  • 3
  • 0
  • 1
filipvisnjic
Tuning in
72 Views
Message 2 of 4
Flag for a moderator

Re: Area 15 - Terrible download speed!

Same problem here with upload speed. First two weeks constant disruptions to internet, and the last two weeks terrible upload speeds. Can't use video chat, send files, email attachments take forever to include and usually followed by errors, etc etc. Already spent over £30 this month on extra 4g data so I can upload. For the last 15 years I have never had so many problems with internet as I have had in the last 4 weeks with Virgin. Awful and unacceptable in this day and age.

0 Kudos
Reply
  • 7.2K
  • 173
  • 420
Forum Team
Forum Team
59 Views
Message 3 of 4
Flag for a moderator

Re: Area 15 - Terrible download speed!

Hi RuiSamuel, 

 

Welcome to the forums, I am sorry to see you have been having trouble with your connection. 

 

I have taken a look and your upstream power levels are too high but the downstream power levels are much too low. This will not be helping your speeds or general connection. 

 

I would like to get an engineer out to have this corrected for you. 


I will pop you a PM to get this arranged, keep an eye out for the Purple Envelope, top right hand corner. 

 

Speak to you soon. 

 

Emma


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 7.2K
  • 173
  • 420
Forum Team
Forum Team
55 Views
Message 4 of 4
Flag for a moderator

Re: Area 15 - Terrible download speed!

Hi filipvisnjic, 

 

I am sorry to see you have also been having trouble with your connection. 

 

I have taken a look and things look ok from this side although I can see the connection has had some trouble with slow speeds in the past. 

 

How are things looking for you now? Fingers crossed there has been an improvement. 

 

All the best

 

Emma


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply