Menu
Reply
  • 15
  • 0
  • 1
vineonline
Tuning in
75 Views
Message 1 of 4
Flag for a moderator

18 months of broadband issues

I've had a fault raised on my account for well over a year now with no updates or resolution.  Broadband keeps dropping off, speeds at between 20-40% of what I'm paying for.  A Virgin Media  engineer came about a year ago and he was baffled as to what the problem is.  When I took my 12 month contract out last year on 4th May I was given a £10/mth discount for 6 months which seemed reasonable in thbe expectation that they seemed to think the solution would be near.  Since then haven't heard anything back.  Have just 39 m ins trying to speak to someone who can give me an update with out luck (after eventually speaking to 5 different people).

Its a huge pain to have to leave but trying to watch iPlayer, Netflix or my Amazon Prime Video membership is unreliable at best (infuriating at worst) so I'm off to BT.  This looks like a reasonable deal  http://www.moneysavingexpert.com/phones/cheap-broadband#btfibre (closes 10th April).

Too tired of constant VM issues and no-one there seems able to help or even point me in the right direction.

 

 

0 Kudos
Reply
  • 21
  • 0
  • 1
jasonukuk
Tuning in
66 Views
Message 2 of 4
Flag for a moderator

Re: 18 months of broadband issues

18 months same here and that much private words over the fixing .
25 march 2017 mine was closed as fixed . i rang them they checked my account and the speed problem was still there .
teck come out and now £10-12 a month they refusing to pay any more,

option to leave .

the fix as not been fixed as i over heard the cause which is the old n*l wiring @ manchester . which part fixed and mine part wasnt .
  • 21
  • 0
  • 1
jasonukuk
Tuning in
65 Views
Message 3 of 4
Flag for a moderator

Re: 18 months of broadband issues

oh at the place were the feed comes from exchange .

0 Kudos
Reply
  • 15
  • 0
  • 1
vineonline
Tuning in
56 Views
Message 4 of 4
Flag for a moderator

Re: 18 months of broadband issues

I'm in Bolton BL6 so I expect mine is the same issue. Seems to have got worse over time too
0 Kudos
Reply