Menu
Reply
  • 17
  • 0
  • 1
cooky560
Tuning in
779 Views
Message 1 of 16
Flag for a moderator

Block ICMP requests

Since getting a Superhub 3 I've been unable to pass the grc shields up! test because of the fact it responds to the ICMP ping request. On the superhub 2 this was configurable from the firewall page, however it seems to be absent now?

0 Kudos
Reply
  • 979
  • 29
  • 87
Martin_D
Well-informed
772 Views
Message 2 of 16
Flag for a moderator

Re: Block ICMP requests

Hi, Cooky560

If you what to block ICMP, You will have to enable the firewall on the hub 3.0


Welcome to the most friendliest community.

Have you got technical problem post it and we will help you fix it.
0 Kudos
Reply
  • 17
  • 0
  • 1
cooky560
Tuning in
745 Views
Message 3 of 16
Flag for a moderator

Re: Block ICMP requests

the firewall is enabled, however it doesn't block ICMP, it responds

0 Kudos
Reply
  • 2.83K
  • 48
  • 364
Buffer6
Trouble shooter
734 Views
Message 4 of 16
Flag for a moderator

Re: Block ICMP requests

0 Kudos
Reply
  • 13.66K
  • 720
  • 4.73K
Superuser
Superuser
727 Views
Message 5 of 16
Flag for a moderator

Re: Block ICMP requests

While the link is useful to those who are directly connecting windows machines to the net.  It's not applicable here as it's the router that responds to pings.

@James_W

Do the firmware team have any plans to put the ability to block ICMP responses back into the hub 3.

If you'll recall, originally it blocked pings with no ability to disable/enable the feature, short of disabling the firewall entirely, which then broke port forwarding.  Later firmware allowed the hub to respond to pings - but again gave no option to disable it should a user wish to.

I stated during the trials that this option should have been put back in.  It really should have been actioned IMHO.

Ravenstar68

________________________________________


Only use Helpful answer if your problems been solved.

  • 2.83K
  • 48
  • 364
Buffer6
Trouble shooter
718 Views
Message 6 of 16
Flag for a moderator

Re: Block ICMP requests

On checking my own set-up my firewall is managed by McAfee I use SHub3 with the firewall enabled and the result of the shieldsup test are

 

sheildsup test.JPG

0 Kudos
Reply
  • 13.66K
  • 720
  • 4.73K
Superuser
Superuser
710 Views
Message 7 of 16
Flag for a moderator

Re: Block ICMP requests

@Buffer6 - The UPnP test doesn't test ICMP echo response.which is what the OP was posting about.

If you do a common ports test, Shields up will also try and ping the computer.

Ravenstar68

________________________________________


Only use Helpful answer if your problems been solved.

  • 2.83K
  • 48
  • 364
Buffer6
Trouble shooter
704 Views
Message 8 of 16
Flag for a moderator

Re: Block ICMP requests

@Ravenstar Point taken.  If the ping echo were blocked then the TBB Monitor wouldn't work, so I suppose that's why it had to be default enabled in SHub3 when it was found that TBB monitor wouldn't work with the firewall enabled. Whereas in the SHub2ac it had the option to turn it on and off so as to enable the TBB monitor.  Quite right this option was not included after being reported in the trials.

 

0 Kudos
Reply
  • 12.71K
  • 1.62K
  • 3.74K
Superuser
Superuser
696 Views
Message 9 of 16
Flag for a moderator

Re: Block ICMP requests

@ravenstar68 How about this one then? https://mxtoolbox.com/PingLookup.aspx

I tested my hub 3 against it and got this:

echo.png

- - - - - -
Any opinions expressed by myself are entirely my own and do not represent Virgin Media in any way.
  • 13.66K
  • 720
  • 4.73K
Superuser
Superuser
694 Views
Message 10 of 16
Flag for a moderator

Re: Block ICMP requests

What hub are you using Shelke?

________________________________________


Only use Helpful answer if your problems been solved.

0 Kudos
Reply