Menu
Reply
  • 24
  • 0
  • 1
DeanH67
Tuning in
1,262 Views
Message 1 of 5
Flag for a moderator

"Can't establish secure connection"

I have been trying to upload some Cds to my Google Play Music account and keep getting the error '"Can't establish secure connection" I have spoken to google and they have said it is a problem with my Internet provider.

Can anyone help and advise what the issue may be.

0 Kudos
Reply
  • 24
  • 0
  • 1
DeanH67
Tuning in
1,233 Views
Message 2 of 5
Flag for a moderator

Re: "Can't establish secure connection"

Well, I thought I would have at least had some form of acknowledgement about this issue from someone at VM

0 Kudos
Reply
  • 12.48K
  • 353
  • 1.45K
Forum Team
Forum Team
1,194 Views
Message 3 of 5
Flag for a moderator

Re: "Can't establish secure connection"

Hi DeanH67,

Sorry for not replying sooner but we are rather busy at the moment so our response times are slower than usual, apologies for the wait.

May I ask what device you are having this problem on? 

I have located the Google Play Forum which has a thread on this subject, so would advise that you take a look at it, hopefully it will be of help.

Keep us updated though if you need further help, and welcome to our Community Smiley Happy

Best wishes,

 


Jen
Forum Team



0 Kudos
Reply
  • 7.18K
  • 233
  • 524
Forum Team
Forum Team
1,153 Views
Message 4 of 5
Flag for a moderator

Re: "Can't establish secure connection"

Hi DeanH67,

 

Just checking back with you to see how it's going with the problem you reported using Google Play Music. Was the Google Play Forum any help for you?

 

Please let us know,


Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos
Reply
  • 1
  • 0
  • 0
Charlie_d-1
Joining in
714 Views
Message 5 of 5
Flag for a moderator

Re: "Can't establish secure connection"

I had this problem too with a particular website.

I tried all the usual browsers - Chrome, Edge, Internet Explorer. They all said "This site can’t provide a secure connection".
Then I reached out to the site on social media, they said everything was operating as usual, other user had no issues, and it must be something with my internet settings.
I also tried temporarily disabling the Firewall on the virgin media box, but it had no effect.

In the end, I downloaded Tor browser which worked.

0 Kudos
Reply