Menu
Reply
Joining in
  • 2
  • 0
  • 0
Registered: ‎11-06-2016
Message 1 of 5 (582 Views)

"Can't establish secure connection"

I have been trying to upload some Cds to my Google Play Music account and keep getting the error '"Can't establish secure connection" I have spoken to google and they have said it is a problem with my Internet provider.

Can anyone help and advise what the issue may be.

Reply
0 Kudos
Joining in
  • 2
  • 0
  • 0
Registered: ‎11-06-2016
Message 2 of 5 (553 Views)

Re: "Can't establish secure connection"

Well, I thought I would have at least had some form of acknowledgement about this issue from someone at VM

Reply
0 Kudos
Forum Team
  • 11.77K
  • 332
  • 1.33K
Registered: ‎23-11-2011
Message 3 of 5 (514 Views)

Re: "Can't establish secure connection"

[ Edited ]

Hi DeanH67,

Sorry for not replying sooner but we are rather busy at the moment so our response times are slower than usual, apologies for the wait.

May I ask what device you are having this problem on? 

I have located the Google Play Forum which has a thread on this subject, so would advise that you take a look at it, hopefully it will be of help.

Keep us updated though if you need further help, and welcome to our Community Smiley Happy

Best wishes,

 


Jen
Forum Team


Tech fan? Have you read our Digital life blog yet? Check it out


Reply
0 Kudos
Forum Team
  • 4.73K
  • 152
  • 357
Registered: ‎07-04-2015
Message 4 of 5 (473 Views)

Re: "Can't establish secure connection"

Hi DeanH67,

 

Just checking back with you to see how it's going with the problem you reported using Google Play Music. Was the Google Play Forum any help for you?

 

Please let us know,


Who's who? Find out more about our community members. Good folk to know


Reply
0 Kudos
Joining in
  • 1
  • 0
  • 0
Registered: a week ago
Message 5 of 5 (34 Views)

Re: "Can't establish secure connection"

I had this problem too with a particular website.

I tried all the usual browsers - Chrome, Edge, Internet Explorer. They all said "This site can’t provide a secure connection".
Then I reached out to the site on social media, they said everything was operating as usual, other user had no issues, and it must be something with my internet settings.
I also tried temporarily disabling the Firewall on the virgin media box, but it had no effect.

In the end, I downloaded Tor browser which worked.

Reply
0 Kudos