Menu
Reply
  • 8
  • 0
  • 0
marcusdempsey
Joining in
488 Views
Message 1 of 19
Flag for a moderator

Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hello,

I've had the Superhub 3 for a few months now using 200Mbits with out any issues when its been in the default router mode.  However I've finally got around to putting it into modem mode and I've suddenly lost around 150Mbits when connected this way.  I'm getting between 50Mbits - 77Mbits when using speedcheck.net

If I put it back into router mode I get the full bandwidth again.

I'm running a DrayTek 2860 router with Cat6 cables and machines that have a 1Gbits connection.  I've power cycled and factory reset both devices to rule out any issues, and even contacted VM to ensure everything is right on their side (they say it is).

I've got the latest firmware for the DrayTek - 3.8.4.3_BT

Doing a continuous ping shows numerous timeouts and long reply times to hosts, I'm getting around 25% packet loss.  I've checked MTU values and these are not being fragmented, so its not that.

Has anyone experienced this before?  I've found quite a few posts about the similar issue, but on Superhub 2.

SUPERHUB 3 INFORMATION

Item Status Comments

Acquired Downstream Channel(Hz)
299000000
Locked
Ranged Upstream Channel(Hz)
39400000
Locked
Provisioning State
Online

 

Downstream bonded channels Channel Frequency(Hz) Power
(dBmV) SNR
(dB) Modulation Channel ID

1299000000-1.737.3256 qam13
2323000000-1.237.6256 qam16
3315000000-1.437.3256 qam15
4307000000-1.537.3256 qam14
5291000000-1.937.3256 qam12
6283000000-237.6256 qam11
7275000000-237.6256 qam10
8267000000-1.737.6256 qam9
9259000000-1.737.3256 qam8
10251000000-1.237.3256 qam7
11243000000-1.237.6256 qam6
12235000000-137.3256 qam5
13227000000-0.937.6256 qam4
14219000000-0.537.6256 qam3
15211000000-0.437.6256 qam2
16203000000-0.237.6256 qam1

 

Upstream bonded channels Channel ID Frequency(Hz) Mode Power
(dBmV) Modulation Channel Bandwidth(Hz) Symbol Rate (ksps)

7439400000ATDMA45.364 qam64000005120
7346200000ATDMA45.364 qam64000005120

 

Operational Configuration General Configuration Value

Network access
Enabled
Maximum Number of CPEs
1
Baseline Privacy
Enabled
Docsis Mode
Docsis30
Config file
V0dea97109ea7aa00.cm
Primary Downstream Service Flow
SFID398542
Max Traffic Rate230000000
Primary Upstream Service Flow
SFID398541
Max Traffic Rate12700000


Theres nothing in the network log for the superhub thats recent.

Marcus

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
437 Views
Message 2 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hi Marcus,

 

Welcome to the community and thanks for posting.

 

Sorry to read there is a difference in speed when using the Hub 3.0 in modem mode.

 

I've run some tests on your connection, the line and hub have come back as fine, which is good.

 

Were the test results of 50 - 77 Mbps completed when the Draytek was connected? If so what speeds do you get if you are connected directly to the Hub without the Draytek attached?

Is there a QoS setting within your router that may need changing?

 

Let me know how you get on

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 1.22K
  • 92
  • 229
stevedh2
Knows their stuff
434 Views
Message 3 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hi I am using a draytek 2850 in modem mode with a hub3. I can only have a Vivid 100Mbit connection so can't comment on whether or not it could handle a 200Mbit but I can pretty much max out my 100 connection.

1stly your Draytek 2860 has a sort of dashboard you can look at. when doing a speed test what is the CPU doing?

Also do you have any Qos Settings etc set up, basically go through and disable everything you can just to check and see if any of the setting could be slowing things down.

Also what do you get when you ping the hub at 192.168.100.1 from your pc via the Draytek.

And this is unlikely to effect you, but when I had 2 Ethernet connections to my pc from the router (honest there was a good reason for that), it really slowed down my internet.

 

 

0 Kudos
Reply
  • 8
  • 0
  • 0
marcusdempsey
Joining in
428 Views
Message 4 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hello,

Since logging this, I've ruled out the DrayTek being the issue, I've tried new patch leads and 2 new routers (different brands) which I know can handle 1Gbps without any dropouts, so I know its now the VM router.  I also tested my DrayTek at another place and has no issues what so ever up to 1Gbps.

When pinging anything internally within my network I get well under 1ms (including pinging my router), as shown below:

PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=0.347 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=0.465 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=0.423 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=0.424 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=0.469 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=255 time=0.446 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=255 time=0.306 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=255 time=0.417 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=255 time=0.321 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=255 time=0.297 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=255 time=0.373 ms
64 bytes from 192.168.1.1: icmp_seq=11 ttl=255 time=0.415 ms
64 bytes from 192.168.1.1: icmp_seq=12 ttl=255 time=0.428 ms
64 bytes from 192.168.1.1: icmp_seq=13 ttl=255 time=0.466 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=255 time=0.447 ms
64 bytes from 192.168.1.1: icmp_seq=15 ttl=255 time=0.305 ms
64 bytes from 192.168.1.1: icmp_seq=16 ttl=255 time=0.407 ms
64 bytes from 192.168.1.1: icmp_seq=17 ttl=255 time=0.410 ms
64 bytes from 192.168.1.1: icmp_seq=18 ttl=255 time=0.377 ms
64 bytes from 192.168.1.1: icmp_seq=19 ttl=255 time=0.470 ms
64 bytes from 192.168.1.1: icmp_seq=20 ttl=255 time=0.342 ms
64 bytes from 192.168.1.1: icmp_seq=21 ttl=255 time=0.456 ms
64 bytes from 192.168.1.1: icmp_seq=22 ttl=255 time=0.470 ms
64 bytes from 192.168.1.1: icmp_seq=23 ttl=255 time=0.434 ms
64 bytes from 192.168.1.1: icmp_seq=24 ttl=255 time=0.404 ms
64 bytes from 192.168.1.1: icmp_seq=25 ttl=255 time=0.398 ms
64 bytes from 192.168.1.1: icmp_seq=26 ttl=255 time=0.316 ms
64 bytes from 192.168.1.1: icmp_seq=27 ttl=255 time=0.454 ms
64 bytes from 192.168.1.1: icmp_seq=28 ttl=255 time=0.368 ms
64 bytes from 192.168.1.1: icmp_seq=29 ttl=255 time=0.351 ms
64 bytes from 192.168.1.1: icmp_seq=30 ttl=255 time=0.458 ms
64 bytes from 192.168.1.1: icmp_seq=31 ttl=255 time=0.332 ms
64 bytes from 192.168.1.1: icmp_seq=32 ttl=255 time=0.494 ms
64 bytes from 192.168.1.1: icmp_seq=33 ttl=255 time=0.462 ms
64 bytes from 192.168.1.1: icmp_seq=34 ttl=255 time=0.453 ms
64 bytes from 192.168.1.1: icmp_seq=35 ttl=255 time=0.439 ms
64 bytes from 192.168.1.1: icmp_seq=36 ttl=255 time=0.463 ms
64 bytes from 192.168.1.1: icmp_seq=37 ttl=255 time=0.443 ms
64 bytes from 192.168.1.1: icmp_seq=38 ttl=255 time=0.413 ms
64 bytes from 192.168.1.1: icmp_seq=39 ttl=255 time=0.425 ms
64 bytes from 192.168.1.1: icmp_seq=40 ttl=255 time=0.437 ms
64 bytes from 192.168.1.1: icmp_seq=41 ttl=255 time=0.427 ms
64 bytes from 192.168.1.1: icmp_seq=42 ttl=255 time=0.314 ms
64 bytes from 192.168.1.1: icmp_seq=43 ttl=255 time=0.380 ms
64 bytes from 192.168.1.1: icmp_seq=44 ttl=255 time=0.329 ms
64 bytes from 192.168.1.1: icmp_seq=45 ttl=255 time=0.426 ms
64 bytes from 192.168.1.1: icmp_seq=46 ttl=255 time=0.416 ms
64 bytes from 192.168.1.1: icmp_seq=47 ttl=255 time=0.383 ms
64 bytes from 192.168.1.1: icmp_seq=48 ttl=255 time=0.415 ms
64 bytes from 192.168.1.1: icmp_seq=49 ttl=255 time=0.336 ms
64 bytes from 192.168.1.1: icmp_seq=50 ttl=255 time=0.409 ms
64 bytes from 192.168.1.1: icmp_seq=51 ttl=255 time=0.421 ms
64 bytes from 192.168.1.1: icmp_seq=52 ttl=255 time=0.438 ms
64 bytes from 192.168.1.1: icmp_seq=53 ttl=255 time=0.795 ms
64 bytes from 192.168.1.1: icmp_seq=54 ttl=255 time=0.414 ms
64 bytes from 192.168.1.1: icmp_seq=55 ttl=255 time=0.302 ms
64 bytes from 192.168.1.1: icmp_seq=56 ttl=255 time=0.367 ms
64 bytes from 192.168.1.1: icmp_seq=57 ttl=255 time=0.461 ms

--- 192.168.1.1 ping statistics ---
58 packets transmitted, 58 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.297/0.411/0.795/0.073 ms

If I ping anything on the internet, Google DNS in this case, response times are bad. If I leave it long enough I can get up to 25% packet loss.


PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=57 time=28.581 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=57 time=28.225 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=57 time=31.875 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=57 time=31.302 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=57 time=532.938 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=57 time=610.315 ms
Request timeout for icmp_seq 6
64 bytes from 8.8.8.8: icmp_seq=6 ttl=57 time=1058.586 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=57 time=784.021 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=57 time=38.076 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=57 time=30.612 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=57 time=28.405 ms
64 bytes from 8.8.8.8: icmp_seq=11 ttl=57 time=33.427 ms
64 bytes from 8.8.8.8: icmp_seq=12 ttl=57 time=29.777 ms
64 bytes from 8.8.8.8: icmp_seq=13 ttl=57 time=31.306 ms
64 bytes from 8.8.8.8: icmp_seq=14 ttl=57 time=913.714 ms
64 bytes from 8.8.8.8: icmp_seq=15 ttl=57 time=1195.756 ms
64 bytes from 8.8.8.8: icmp_seq=16 ttl=57 time=919.102 ms
64 bytes from 8.8.8.8: icmp_seq=17 ttl=57 time=672.882 ms
64 bytes from 8.8.8.8: icmp_seq=18 ttl=57 time=36.541 ms
64 bytes from 8.8.8.8: icmp_seq=19 ttl=57 time=30.531 ms
64 bytes from 8.8.8.8: icmp_seq=20 ttl=57 time=31.948 ms
64 bytes from 8.8.8.8: icmp_seq=21 ttl=57 time=31.439 ms
64 bytes from 8.8.8.8: icmp_seq=22 ttl=57 time=29.905 ms
^C
--- 8.8.8.8 ping statistics ---
23 packets transmitted, 23 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 28.225/311.272/1195.756/403.275 ms

If I traceroute to Google DNS I get some shocking times on the VM network, notice that its under 1ms when it hits my router.

1 192.168.1.1 (192.168.1.1) 0.765 ms 0.265 ms 0.200 ms
2 * * *
3 midd-core-2b-xe-123-0.network.virginmedia.net (62.252.68.157) 15.462 ms 14.812 ms 12.594 ms
4 * * *
5 tcl5-ic-4-ae5-0.network.virginmedia.net (62.252.192.246) 35.198 ms 27.655 ms 28.180 ms
6 m358-mp2.cvx3-a.ltn.dial.ntli.net (213.104.85.102) 27.881 ms
246-14-250-212.static.virginm.net (212.250.14.246) 29.642 ms 51.218 ms
7 108.170.246.161 (108.170.246.161) 24.270 ms
108.170.246.129 (108.170.246.129) 25.287 ms
108.170.246.193 (108.170.246.193) 29.681 ms
8 216.239.57.57 (216.239.57.57) 23.272 ms
216.239.58.57 (216.239.58.57) 31.079 ms
209.85.245.143 (209.85.245.143) 30.802 ms
9 google-public-dns-a.google.com (8.8.8.8) 29.489 ms 29.496 ms 30.204 ms

After doing some research, I believe its down to the Intel Puma 6 chip in the modem that can experience these symptoms.  There is a 30 page thread on this on another VM forum - http://community.virginmedia.com/t5/Gaming-Support/Hub-3-Compal-CH7465-LG-TG2492LG-and-CGNV4-Latency...

When you also google for the Superhub3 and the Intel Puma 6, you get a lot of pages about latency etc.  Another article is here: https://www.theregister.co.uk/2016/12/03/intel_puma_chipset_firmware_fix/

Marcus

0 Kudos
Reply
  • 8.3K
  • 516
  • 2.3K
Superuser
Superuser
421 Views
Message 5 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Whilst the issue you mention will affect latency, it wont knock 150MBps off your speed.

You got CAT6 from HUB3 to DrayTek? HUB3 is picky about cables...

Have you rebooted HUB3 recently?

 

 


0 Kudos
Reply
  • 8
  • 0
  • 0
marcusdempsey
Joining in
418 Views
Message 6 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Even with the other routers I was still only getting a max of 70Mbps.  Yeah I've tried brand new cat6 1/2 meter patch leads, going from laptop -> draytek -> superhub.

I've even tried putting a switch in between the draytec and the superhub with no change in speed.

The superhub has been rebooted a few times lately with no change.  

Marcus

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
409 Views
Message 7 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Morning Marcus,

 

Thanks for getting back to us.

 

Is there a difference in speed if you complete a factory reset of the Hub 3.0?

 

Do other devices notice the change in speeds?

 

If you complete a speed test now in router mode will you achieve 200 Mbps, connected directly to the Hub 3.0?

 

Speak soon

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 8
  • 0
  • 0
marcusdempsey
Joining in
407 Views
Message 8 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hi Sam,

If I perform a factory reset of the Hub 3 I see no difference in performance when in modem mode - maximum 70Mbps, but average 40-50Mbps.

All devices achieve the same speed, whether connected wirelessly or wired to the Hub 3.

If I complete a speed test when connected directly to the hub 3 in router mode I will achieve the 200Mbps.  However, I need to run the hub in modem mode, due to compliance reasons (mainly that theres a ton of securely flaws exposed when in router mode on the hub 3).  Running same test when in router mode (no matter what router I add to the back of it, achieves a max of 70Mbps).

This appears to only affect download speeds, I max out the upload of 12Mbps during these tests

Marcus

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
407 Views
Message 9 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hi Marcus,

 

I appreciate all the tests you have completed and the information provided, it does help us further.

 

I've sent you a PM (purple envelope icon, right corner) with some additional details.

 

Speak soon

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 1.22K
  • 92
  • 229
stevedh2
Knows their stuff
404 Views
Message 10 of 19
Flag for a moderator

Re: Superhub 3 - Modem mode slow bandwidth with DrayTek 2860 router

Hi Marcus,

Did you ever try pinging the hub while in modem mode at 192.168.100.1 ?

Also when connected in Modem mode do the lights at both ends indicate that the ports are synced at 1gpbs.

It may be worth telneting into the Draytek and typing

port status and see what it tells (not sure if it includes the Wan port on the 2860.. it does on the 2850, but the 2850s wan port can also be a lan port).

People have had ethernet related issues with the Hub3...


also you could try a different report after resetting the Hub, as it appears in modem mode it uses whatever port it is 1st connected to as apposed being locked to port 4.

 

 

 

0 Kudos
Reply