Menu
Reply
  • 69
  • 0
  • 8
grindax
On our wavelength
7,605 Views
Message 1 of 221
Flag for a moderator

Can't turn off 'Advanced Network Error Search'

Virgin Media won't let me turn off 'Advanced Network Error Search', aka Virgin Media DNS Hijacking.

 

I turned it off long ago at the page that is supposed to allow this:

https://my.virginmedia.com/advancederrorsearch/settings

 

And even if I go to that page now, it tells me that it's already turned OFF.

 

However, I'm still getting the unwanted search results when trying to access a non-existant domain name.

 

I've already rebooted the cable modem, rebooted PC, cleared browser cache (and tried multiple different browsers on multiple different PCs on my home network), etc.

 

How can I get this turned off once and for all? (Without having to spend further time on this by phoning someone in the call centre who won't understand what I'm asking for).

  • 9.37K
  • 362
  • 2.31K
Superuser
Superuser
7,592 Views
Message 2 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

If VM's setting is not working currently then the only way is to change your DNS setting for each computer to an alternative, like OpenDNS: http://www.opendns.com/

 

How to change your DNS settings on windows: http://help.virginmedia.com/system/selfservice.controller?CMD=VIEW_ARTICLE&ARTICLE_ID=3808&CURRENT_C...

 

You will need to change it for both wired and wireless to avoid having the VM DNS on one and OpenDNS on the other.

 

OpenDNS is preferable anyway.

 

Once you've changed it all URL lookups will go through OpenDNS and any sites it can't find it'll present it's own search alternative.

 

0 Kudos
Reply
  • 69
  • 0
  • 8
grindax
On our wavelength
7,583 Views
Message 3 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Thanks MUD_Wizard, however I'm looking for the problem to be solved, not for a workaround. I used OpenDNS in the past and found it to be slightly slower. Also, it is sub-optimal when it comes to clicking on download links that rely on geolocation to provide the best performance.

 

Anyway, what I'm interested in is knowing why the functionality that VM supposedly provide to turn this "service" off doesn't work.

 

It tells me it's off, but it is clearly still on. I didn't ask for this "service" and it's unacceptable that I can't even opt out.

 

Can someone from Virgin Media please reply.

0 Kudos
Reply
  • 13
  • 0
  • 1
Migglezimblatt
Tuning in
7,497 Views
Message 4 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

This seems to be an endemic problem. I turned it off years ago too but now it's back on and I can't turn it off. I did log a call about this and did speak to a nice person from 2nd line support who said he would investigate. After a couple of days he called me back and left a message on my answering machine suggesting that I reboot my computer.

 

SERIOUSLY?!?!!!!!???!

 

I am absolutely appalled by that. Do they really think I'm that stupid?

 

It is broken, and its a shame but they cant see that. I really didn't expect this from virgin media - I have been a customer for about 16 years (since it was bradford cable, then yorkshire cable, then telewest, then blueyonder, now virgin media) and have been impressed with their technical ability in the past. But this is shocking.

 

nslookup www.jdjdidjdidjdidjdudhfdidhdidhdi.com

answer:

81.200.64.50

 

nslookup 81.200.64.50

answer: 

advancedsearch.virginmedia.com

 

its not rocket science...

 

0 Kudos
Reply
  • 9.1K
  • 300
  • 978
Forum Team
Forum Team
7,483 Views
Message 5 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Hello grindax

 

I show you on our database here as opting out and personally I agree with you. I will try a toggle, I have opted you back in on the main server. Please would you log into MYVM and opt out again.

 

Thanks

Nicola

Virgin Media Forum Team
0 Kudos
Reply
  • 9.1K
  • 300
  • 978
Forum Team
Forum Team
7,481 Views
Message 6 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Hello Migglezimblatt

 

Same as grindax, I have opted you back in, please would you opt out again on MYVM and let us know if this fixes it.

 

Thanks for your help

Nicola

Virgin Media Forum Team
0 Kudos
Reply
  • 13
  • 0
  • 1
Migglezimblatt
Tuning in
7,468 Views
Message 7 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Nicola_C

 

Many thanks for your swift response. Unfortunately turning it back on has had no effect. The website says I have successfully switched it off (and warns me its already off if I try it a second time) but the nslookups are still returning the advanced error search.

 

all help appreciated,

 

-M

0 Kudos
Reply
  • 248
  • 14
  • 70
bromham
Superfast
7,461 Views
Message 8 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

I've just tried turning it off on my connection and it's had no effect.  DNS hijacking is still happening, so the opt-out is definitely broken.

 

Forum team: is there any way of reporting obvious faults to someone in VM who both understands technical issues and has the ability to fix them?

0 Kudos
Reply
  • 9.1K
  • 300
  • 978
Forum Team
Forum Team
7,451 Views
Message 9 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Hello Migglezimblatt

 

Thanks for getting back, an interesting problem? I have raised the issue to our IT team to make sure our databases our reporting correctly to the network servers. Ref P005651649. After that it may need to go to the network team. We will do our best to keep this thread updated. Did you try a flush DNS on the PC by the way? I'm only asking as I might be asked it lol.

 

 

Thanks

Nicola

Virgin Media Forum Team
0 Kudos
Reply
  • 9.1K
  • 300
  • 978
Forum Team
Forum Team
7,449 Views
Message 10 of 221
Flag for a moderator

Re: Can't turn off 'Advanced Network Error Search'

Hello bromham

 

You may be correct that it's a widespread problem. I will see how it goes first with Migglezimblatt P005651649 if you don't mind, see if we flush out a wider problem, as soon as I know more I will let you know.

 

Thanks

Nicola

Virgin Media Forum Team
0 Kudos
Reply