Menu
Reply
  • 1
  • 0
  • 1
Adams1101
Joining in
76 Views
Message 1 of 3
Flag for a moderator

Activation issues

Had an engineer visit yesterday morning to set up virgin phone and broadband. He was here 3 and half hours and left with the router flashing green and said it takes up to 24hrs to complete activation. 12 hours later it still wasn't working so thought I'd call them to see what's what. Got through to support who said it's an immediate activation which they just needed to send the activation signals again and for me to switch off the router for few minutes then back on which didn't work. They put me on hold after being on the phone for 20 or so mins then they disconnected! Called back, went through all the same with another staff member, didn't work so they put me on hold...again it DISCONNECTED!
Called back again:.. and they said exactly the same to resend the activation signals and to reboot the routers but didn't work; they said they need to get an engineer out which will be the following Monday so well over a week! They also said 'as a gesture of goodwill' they won't charge me until it is all connected and working..:.REALLY?! That's goodwill??

I left BT as their service was all round going downhill and thought virgins 'super easy setup and super speeds would be the ideal replacement...hmm. No one is really willing to pull their finger out and assist... expecting a call from someone at virgin to get this working asap.
  • 5
  • 0
  • 1
Lasastar
Tuning in
68 Views
Message 2 of 3
Flag for a moderator

Re: Activation issues

Your story is the same as mine, the support has been shocking from virgin. I too have been disconnected whilst on hold.

Seriously considering cancelling whilst in the 14 day period.

  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
40 Views
Message 3 of 3
Flag for a moderator

Re: Activation issues

Hi Adams1101,

 

Welcome to the community and thanks for posting.

 

My apologies for the delay in activating the broadband service and for the engineer appointment.

 

I've taken a look into this and there has been an issue with the activation of the services which will require an engineer appointment to get this resolved.

 

I appreciate this is frustrating to say the least.

 

Let us know how the visit goes

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply