Menu
Reply
  • 6
  • 0
  • 0
Why1009
Joining in
1,097 Views
Message 1 of 9
Flag for a moderator

iPhone do not connect despite correct password

Just putting this first. Do not ask me to contact support. They had given me at least 10 different reasons as to why it is not their problem and do not wish to help at all. Only ONE out of many offer a temporary solution which no longer seems to work.

I have spent an entire week trying to solve this and support has been disastrous.

I have an iPhone that is up to date to newest IOS along other devices. I have been a loyal virgin media customer, but it has been a downhill journey since last winter. Initially the there was difficulties to have a constant network, as it keeps disappearing. I tried contacting support and it took me a whole 4 months to convince them that the problem is with the Hub, after replacing the hub, all has been great till this winter.

It started off as occasionally slow speeds. Then sudden disconnection on some devices, but not with a pattern, these problems appears inconsistently and everytime I contact support they just say, looks fine here, I don't care about your connection. Looks fine here. Until one kind soul offered a solution and it solved it! It only took 10 mins that other support members refuse to spend.

However yesterday and today the problem has been absolutely unsolvable. Entering the password for my network is considered incorrect when many others are connected to the network. For 5G the incorrect password box pops up while the 2G display a yellow message saying no internet connection(Contacting the ISP did not help obviously) after I tried to figure out what is wrong with the hub. I have done many things REPEATEDLY
-Reboot Hub

-Hard reset Hub

-Rollback IOS update

-Factory reset

-Network reset

-Changes channels

-change passwords

-Connect them one by one

-Press the WPS as suggested by some articles (2G finally accept the SAME password but display yellow message

Abused google for solutions and at no veil.

I am currently looking for other networks for phone data as this is absurd, but still would like kind souls to troubleshoot this for me. Thank you very much

0 Kudos
Reply
  • 10.01K
  • 294
  • 625
Forum Team
Forum Team
1,055 Views
Message 2 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Hey there Why1009,

 

Thanks for posting and a big welcome to the community Smiley Very Happy

 

Wow this sounds like a frustrating fault! As an Apple user myself, I know the products can be temperamental but I've never experienced it being this difficult to connect.

 

It sounds like you've covered absolutely everything that I would suggest. Does you phone connect on other wireless networks?

 

Hope to hear back from you soon,

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
  • 6
  • 0
  • 0
Why1009
Joining in
1,043 Views
Message 3 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Well, I was writing a detailed response until the internet cuts out and I lost all I wrote.

Venting aside...

Situation:
-ALL devices connects fine in other networks, private, public or hotspots. Encryption do not seem to matter either

-The no internet problem occurs at random. For 2G, it displays a connected but no internet message for iPhones while windows trouble shooter suggests restart the hub or can not identity the problem; for 5G it display an incorrect password message while it being correct. Both problems seems to only affect iPhones and windows laptops, hence the support team has been blaming my devices instead of trouble shooting for me. Android phones and Mac do not seem to not affected as much, i own the only windows laptop on the network therefore it has been difficult to trouble shoot this with different windows system. However for iPhones, it does seem to be affecting all iPhones, 2 in particular, but I have not identify the difference between these two and others. (Initially I thought it was IOS 8 causing problem, but all devices are on IOS 10 now). This problem is the major crippling one, but it is random and each time it affects different devices. Only viable fix is to reboot the hub until it magically fix itself, but it become an annoyance when you reboot it twice in an hour.

-My current solution is to work on the floor with an Ethernet connection as it seem to be the most stable, despite being uncomfortable. But it is not free of problems, occasionally it disconnects and windows trouble shoots gives a message saying that 'Your computer appears to be configure correctly, the website might be down(bbc.co.uk)' however the website still can be accessed through wifi or 4G.

-Slow wifi speed is also another frustrating problem too and many visitors who use the wifi also reflected this. Although this is less important relative to the disconnections.

-Support has offered numberous suggestions that has failed to work consistenly or simply impossible to achieve. One even suggested 'deal with it' which brought me close to tears, as I share my house with other occupants who pay rent. I face pressure to sort this out for them.

-Perhaps tired of my rentless calls, they made a statement that they are not responsible for wifi problems and when asked if I can seek indepedant help, they do not suggest any. They chose to stick to the explanation that my environment have too much interference. However, I placed my hub in an open space living room with minium walls and obstruction therefore this should not be a problem. The support team do not give further explanation when I told them this. My neighbour in the same area do not have any of these problems, so the support just said the problem will be on my end. One close friend of mine using virgin media can receive connection through 5 walls while I lose connection 5 meters from it. He even joked about it when he visited my house and experienced my connection. The support has stuck to their environment issues on nearly every detail I give them.

-This is a new hub as the old one was replaced after I tried very hard to convience them that there is a problem with hub. But the new hub present more challenges than the old one. My neighbour used the same hub for 2 years now and he does not seem to have a problem.
0 Kudos
Reply
  • 5
  • 0
  • 0
ihatew1nme
Joining in
1,034 Views
Message 4 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

i have a similar problem with my laptop, it will not connect to my wifi it say that since I have restarted my laptop ( I turned it off) but it will not accept my wifi password. so cabled at mo

so if we both have a similar problems it suggest to me that it a wifi problem

0 Kudos
Reply
  • 6
  • 0
  • 0
Why1009
Joining in
1,032 Views
Message 5 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Try uninstalling your driver or update it. Rebooting the hub also may work.
I had this problem with my laptop as well, a kind soul in support team solved it for me.
Go to 'network setting'
Forget the network
And reconnect to the network with the password. This worked for my laptop but not my IPhones.

On a separate note, my laptop has been getting new problems as mention in my previous post.
0 Kudos
Reply
  • 6
  • 0
  • 0
Why1009
Joining in
978 Views
Message 6 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Well, i am still 'dealing with it' Really wish someone could offer some help...

0 Kudos
Reply
  • 5
  • 0
  • 0
Frank04
Tuning in
951 Views
Message 7 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Similar problem here.  Someone at my flat using an iPhone and MacBook Pro keeps getting disconnected on 5g and is now having to connect  via 2G

I can connect via my Android phone to 5G but:

Wifi symbol shows a "!"

Speed on 5g is much slower  ( currently this evening 10Mbps vs 43Mbps on 2G)  - even though my Wifi Analyser app shows many more devices in the local area on 2G than on 5G.  (I have a 100Mb service)

 

 

 

 

 

0 Kudos
Reply
  • 6
  • 0
  • 0
Why1009
Joining in
930 Views
Message 8 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

I don't think we will ever get a response, given that they don't give a damn unless you call support. Even when you do, they create tons of excuses and ask you to call them again if the problem arises again. Spent over 8 hours on phone with them. The only thing changing is my patience and my annoyance with the support. Every call made barely any progress. All solutions are temporary and work at most 1 day. I am bored of waiting 20 mins every day and then spent half an hour talking to them. 3 MONTHS are how long this has been going on.

0 Kudos
Reply
  • 10.01K
  • 294
  • 625
Forum Team
Forum Team
919 Views
Message 9 of 9
Flag for a moderator

Re: iPhone do not connect despite correct password

Hey Why1009,

 

Thanks for getting back in touch, I'm sorry I've not replied sooner, you've just made your way to the front of the queue since your last post.

 

I know you've been through diagnostics many time with tech support, and I can see that you've already had your wireless channel changed.

 

I think it's worth us trying a replacement Hub to rule out the possibility of faulty hardware.

 

I'll drop you a PM (purple envelope, top right) with additional info.

 

Speak soon,

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply