Menu
Reply
  • 23
  • 0
  • 1
haarvh
Tuning in
184 Views
Message 1 of 6
Flag for a moderator

WiFi connection is completely fine, Ethernet won't connect

This has started in the last two days and has been a constant problem (it hasn't changed since it first started).

The WiFi is completely operational and runs fine, but when I try switch to a wired ethernet connection it just stays on "identifying" and "limited connection" - as far as I know nothing has changed between when it was working and now. 

I've tried the troubleshooting options in the Network Sharing Centre and nothing really happened, does anyone have any idea why this would randomly happen?

0 Kudos
Reply
  • 82
  • 6
  • 10
wanderey2
Up to speed
164 Views
Message 2 of 6
Flag for a moderator

Re: WiFi connection is completely fine, Ethernet won't connect

Hi !

When it says "limited connection" could you go to your command prompt (Start->Search, type in"cmd" and press enter). In command prompt, please type in: "ipconfig /all" (without quotes). And copy the results and post it here. It looks like it has got problem to assign IP address. You can also try to disable firewall just to check if that is not causing any issues.

Please post back the result of ipconfig comman so we can look further.

Regards

0 Kudos
Reply
  • 23
  • 0
  • 1
haarvh
Tuning in
158 Views
Message 3 of 6
Flag for a moderator

Re: WiFi connection is completely fine, Ethernet won't connect

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Harvey>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : HarvsPC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Local Area Connection* 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : **:**:**:**:**:**
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter WiFi:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8188EE 802.11bgn Wi-Fi Adapter

Physical Address. . . . . . . . . : **:**:**:**:**:**
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::105a:6c94:fe23:210d%4(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.15(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 24 March 2017 02:16:01
Lease Expires . . . . . . . . . . : 04 April 2017 14:37:07
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 238843878
DHCPv6 Client DUID. . . . . . . . : **:**:**:**:**:**-**:**:**:**:**:**-54-85

DNS Servers . . . . . . . . . . . : 8.8.8.8
8.8.4.4
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
Physical Address. . . . . . . . . : **:**:**:**:**:**
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::b125:52f0:8ec6:dddc%2(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.221.220(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 211830812
DHCPv6 Client DUID. . . . . . . . : **:**:**:**:**:**-**:**:**:**:**:**-54-85

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{E9D09ABE-FFD4-4A5C-9196-CA3F5A97C040}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : **:**:**:**:**:**-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : **:**:**:**:**:**-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6abd:20f9:265:3f57:fff0(Prefe
rred)
Link-local IPv6 Address . . . . . : fe80::20f9:265:3f57:fff0%5(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 150994944
DHCPv6 Client DUID. . . . . . . . : **:**:**:**:**:**-**:**:**:**:**:**-54-85

NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{83E48F6B-D98A-4D36-B553-5FA1998F7383}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
Physical Address. . . . . . . . . : **:**:**:**:**:**-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Users\Harvey>

0 Kudos
Reply
  • 82
  • 6
  • 10
wanderey2
Up to speed
150 Views
Message 4 of 6
Flag for a moderator

Re: WiFi connection is completely fine, Ethernet won't connect

As you can see above, for some reason it did not assign correct IP address as well as Subnet mask.

When you connected the cable, did the system asked you if it is public or home network? If it did, which one did you choose ? (Home, Public, Work ?). You can follow This guide to change it and set it to HOME network.

Alternatively, you can set the IP address, Subnet mask, Gateway and DNS manually.

Are you using any security software which could possibly be blocking your access to the network ?

Regards

 

0 Kudos
Reply
  • 23
  • 0
  • 1
haarvh
Tuning in
146 Views
Message 5 of 6
Flag for a moderator

Re: WiFi connection is completely fine, Ethernet won't connect

For some reason, I can't change the properties of the connection. This is what I see in Network Sharing Centre:
https://gyazo.com/13b553b0811e51546a375bce61f2e237

I'm unable to click the 2nd connection (which should be my ethernet connection).

I'm not using any security software that would block access to the internet
0 Kudos
Reply
  • 82
  • 6
  • 10
wanderey2
Up to speed
137 Views
Message 6 of 6
Flag for a moderator

Re: WiFi connection is completely fine, Ethernet won't connect

Can't you click on "Private network" just underneath the "Unidentified network" ? Also you can try to (disconnect your ethernet cable first) go to Device Manager and uninstall your Realtek Network Card, then restart your computer> after rebooting, it should detect it again and reinstall the driver. After that, just plug the cable in again, and it should ask you for the network type. 

Another thing to try out: disable your Wifi connection, and then try to change the nework type.

If none of the above works, run your command prompt with administrator rights (Start-->Search, type "cmd", right-click and choose "Run as administrator").

In command prompt type in "netsh winsock reset" (without quotes) and hit Enter. It should reset your network settings ti default.

Regards

0 Kudos
Reply