Menu
Reply
  • 6
  • 0
  • 0
RyanTheBrian122
Tuning in
500 Views
Message 1 of 11
Flag for a moderator

Superhub 3 2.4ghz poor speed


Hi, got Vivid 100 installed yesterday it's our first virgin service. Devices connected to 5ghz are at 100mbps but devices connected to the 2.4ghz band are at 30mbps. I know 5ghz is meant to be faster but I want it to be 100mbps on 2.4ghz too. What should I do?
0 Kudos
Reply
  • 1.22K
  • 92
  • 229
stevedh2
Knows their stuff
484 Views
Message 2 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

get a wifi scanner app for you phone and see if your broadband conflicts with any neighbours.

basically have a look at this Getting a better Wireless Network Signal.

note if its crowded then you might actually get betters speed with 20mhz band width as apposed to 40mhz as your less likely to have conflicts.

however that said wifi is a bit of a black art and effected by many factors beyond your control

 

0 Kudos
Reply
  • 6
  • 0
  • 0
RyanTheBrian122
Tuning in
479 Views
Message 3 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

I've tried changing channels. Nothing seems to work. Might give virgin a call. Would they be able to do anything?
0 Kudos
Reply
  • 9.02K
  • 760
  • 1.88K
Superuser
Superuser
461 Views
Message 4 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

Wireless is affected by a myriad of external factors outside VM's or any ISP's control, so if you are getting headline speed all the time with a device wired directly to the hub there is not a lot VM can do unless the hub is faulty.

The first thing to do is to check if you have got the tool for the job, to achieve 100Mbps wirelessly you need a wireless adapter that is capable of using two wireless stream (MIMO) and capable of channel bonding. What wireless devices are you using? (Make / Model)

The big drawback with the 2.4Ghz band that is very narrow and with the ever increasing popularity of wireless gadgets can get quite crowded. For this reason it is best not to use the 40Mhz wide channel as Steve says as it takes up over half of the available spectrum, making it susceptible to wireless interference. Using a single 20MHz wide will restrict the maximum speed to around 35 to 40Mbps per wireless stream.

So to achieve 100Mbps on the 2.4Ghz band you will either need to live in a clean wireless environment where you can use channel bonding without interference and adapters capable of using two wireless streams, or get a three or four wireless stream  router and wireless clients to match.

Have you used a wireless scanner like InSSIDer to help you change the channel. The scanner will show you the neighbouring WiFi networks that could be conflicting with your network. Bear in mind that the scanner will not show interference from other sources like A\V Steaming Devices, Baby Monitors, Chordless Phones, Microwave Ovens, Plasma TVs, Security Systems etc. There is a lot of stuff competing for space on the 2.4Ghz band and is known as the junk band for good reason. It looks like it is going to get worse when Ofcom sell off the 2.3Ghz band.

Obviously, the distance from the wireless client to the hub and whether there are any obstacles inbetween will also affect wireless speed.

 

0 Kudos
Reply
  • 6
  • 0
  • 0
RyanTheBrian122
Tuning in
459 Views
Message 5 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

Is 30-40 Mbps normal for a 2.4ghz connection? I'm giving them a call on Monday just to see if they could send me another hub
0 Kudos
Reply
  • 9.02K
  • 760
  • 1.88K
Superuser
Superuser
453 Views
Message 6 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

I don't know what another hub would achieve.

A 20Mhz wide wireless channel can carry 72Mbps of data theoretical, in one direction. Due to the way wireless works the actual speeds would be around 35 to 40Mbps.

Using two wireless channels bonded together to give you a 40Mhz wide channel will give you a 150Mbs theoretical speed. around 75 to 85 Mbps actual speed.

So if your wireless client has only one antenna and can use only 1 wireless stream then around 30 to 40 Mb[s would be the maximum speed notwithstanding range and interference issues.

If you set the hub and your client to use the 40Mbps wide channel. This would raise the maximum possible speed to around 75 to 85Mbps, but whether you get this or not will depend on how much interference is present, your wifi speeds could get worse.

OBSS software if enabled on the hub will automatically switch you to the 20Mhz wide channel if it senses any interference, so  back to 30 - 40 Mbps.

If your wireless client has 2 antennae then the speeds would double as you are using two wireless streams to transmit data. So if the hub is set to use two wireless streams on the 2.4Ghz band (144Mbps) then you should get around 75 - 85 Mbps on a single 20Mhz wireless channel.

  • 1.22K
  • 52
  • 170
jpeg1
Knows their stuff
443 Views
Message 7 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed


RyanTheBrian122 wrote:

Hi, got Vivid 100 installed yesterday it's our first virgin service. Devices connected to 5ghz are at 100mbps but devices connected to the 2.4ghz band are at 30mbps. I know 5ghz is meant to be faster but I want it to be 100mbps on 2.4ghz too. What should I do?

To be realistic, you are never going to achieve a solid 100Mb/s data rate at 2.4 GHz.  It won't happen.

Why can't you use 5GHz for all your devices?  If it's because they aren't equipped for 5GHz then you'll just have to accept the lower rate.

If it's to take advantage of the greater range that 2.4GHz generally allows, you will lose out anyway because data rate falls off considerably with distance.

  • 6
  • 0
  • 0
RyanTheBrian122
Tuning in
436 Views
Message 8 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

I know I won't get full speed but I'm hoping for atleast 60-80 mbps
0 Kudos
Reply
  • 6
  • 0
  • 0
RyanTheBrian122
Tuning in
437 Views
Message 9 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

How do I set the hub and client to 40mbps wide channel? Sorry I'm not very good with things like this 😂
0 Kudos
Reply
  • 1.22K
  • 52
  • 170
jpeg1
Knows their stuff
423 Views
Message 10 of 11
Flag for a moderator

Re: Superhub 3 2.4ghz poor speed

Log into the hub at 192.168.0.1.

Go to Settings  > WiFi.   Be warned that changing the channel width may not improve the connect speed. It may make it worse, as advised above.

0 Kudos
Reply