Menu
Reply
  • 23
  • 0
  • 1
A_Sweaty_Wombat
Tuning in
3,185 Views
Message 1 of 52
Flag for a moderator

SuperHub 3 slow Wi-Fi

Hi guys,

I got a new SuperHub 3 today, set it up and whatnot. I started connecting devices and I have noticed that wireless devices are getting a much slower connection than they should be.

My iPhone 6s Plus for example is ac enabled and is connected to the SuperHub 3 5GHz frequency with a 1300 Mbps link speed. My mum's iPhone 5s has the same link speed, yet I'm only able to get a 20 Mbps download speed on Speedtest.net. A quarter of the 100 Mbps I usually get. I get the full 100 Mbps speed on my desktop which is connected via Ethernet so there's no problems with the broadband, just the wireless.

The SuperHub is in the same room as me so walls and interference isn't a problem and never has been because I have not had any trouble with speeds through Wi-Fi until today when I set up the SuperHub 3.

Both the 2.4GHz and 5GHz frequencies have their own SSIDs so there's definitely no confusion there. I have also set the channel width to 20/40/80 MHz and I have the security set on WPA2-PSK so the settings shouldn't be the problem. Note, I have also tried the 20/40 MHz width and it reduces the link speed to 450 Mbps but has the same result on Speedtest.net!

Any fixes or reasons for this issue I'm having? I've seen it's quite common among SuperHub 3 users but no actual reason or fix so far.

I'll keep saying this, the speeds were fine until today when I set up the new SuperHub 3 and Ethernet speeds remain unaffected. no matter where I go in the house, it remains around 20 Mbps (give or take a few Mbps per test).

0 Kudos
Reply
  • 32
  • 1
  • 1
Mirr
On our wavelength
3,169 Views
Message 2 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

20 Mbps on 5GHz ? If you reseted the device and no joy, then...

Ask for replacement, no fix. 

btw. IF wired connection is ok...

0 Kudos
Reply
  • 10.82K
  • 308
  • 631
Forum Team
Forum Team
3,137 Views
Message 3 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Hi A_Sweaty_Wombat,

 

Welcome to the community and thanks for posting.

 

Sorry to read that you are experiencing slow wireless speeds.

 

Do you get the same speeds whether you are connected to the 2.4 GHz or 5 GHz network?

Have you tried changing the wireless channel at all?

Try to disable one of the networks, either 2.4 GHz or 5 GHz, then complete a speed test to see if the speeds differ?

You can also try a factory reset of the Hub (be mindful that any saved settings will revert to default), leave the settings as they are and try another speed test.

 

Let me know how you get on

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 23
  • 0
  • 1
A_Sweaty_Wombat
Tuning in
3,132 Views
Message 4 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Hello Samantha_L,

Thanks for replying. Under my tests I have found some extremely strange results that differ massively but here's what I have found so far.

I can achieve 100 Mbps on my iPhone 6s Plus very late at night or very early in the morning. I can also achieve 100 Mbps under certain circumstances when all devices connected via Ethernet are turned off. Switching either of the frequencies off does not affect performance and I can confirm that both 2.4 GHz and 5GHz provide the same results. The only time they differ is when it is possible to achieve 100 Mbps on Wi-Fi because the link speed on the 2.4GHz frequency is only 54 Mbps.

The tests done on Wi-Fi are not affected by fair usage speed limits imposed by Virgin Media as I can go on any device connected via Ethernet and achieve 100 Mbps at any time. I'm not downloading anything on any devices when these tests are done and if I turn off all devices connected to Ethernet it does not always guarantee 100 Mbps on Wi-Fi, just in some circumstances.

I have not performed a factory reset as of yet because I have set up some port forwarding rules recently and don't want to have to do it all again. It is something I might try though.

I must also add something else too which I have noticed whilst testing. On some tests I do on Wi-Fi, I can see that it shoots all the way up to 100 Mbps, but then it falls down to 20 Mbps and cannot go any faster. Sometimes it'll just shoot to 30 Mbps and then fall to 20 Mbps. In some cases I can achieve 30 Mbps.

What I will do is perform a full reset of the SuperHub and redo the tests and see what happens and respond because that is the only thing I have not yet done.

 

Many thanks!

0 Kudos
Reply
  • 23
  • 0
  • 1
A_Sweaty_Wombat
Tuning in
3,124 Views
Message 5 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Hello again,

I have just done a factory reset of the SuperHub and I have not changed a single setting. I immediately checked what speeds I was getting and got 32.38 Mbps download.

I then went to the "connected devices" page to see what the link speed was. On the 5GHz frequency it put me on, I only have a 54 Mbps link speed. Which for a 5GHz Wi-Fi ac enabled device, is light years away from it's 1300+ Mbps link speed capability. I'll adjust a setting for two and see what I can get. If not, I'll completely change the settings around and get it up to 1300 Mbps again for another re-test.

Many thanks.

EDIT: At a loss here... I have tried to reconfigure the settings and I can't get a 1300 Mbps link speed anymore on 5GHz ac. Max now is between 450 and 600 depending on random factors. I did one speed test and got 64 Mbps then re-tested and got 24 Mbps. No idea what is up and I cannot fix it. The software for the SuperHub 3 is unfinished at best.

The 2.4 GHz and 5 GHz frequencies have different names and passwords. The 5 GHz frequency won't allow me to set 80 MHz band like it did before resetting it. The only benefit I gained from the reset is the wireless filter list no longer has errors on it.

0 Kudos
Reply
  • 1
  • 0
  • 0
ridavey
Joining in
2,953 Views
Message 6 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Did you manage to fix this? I have the same problem.
0 Kudos
Reply
  • 23
  • 0
  • 1
A_Sweaty_Wombat
Tuning in
2,950 Views
Message 7 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Hello,

Unfortunately not. To this day it remains an issue. Try using a wireless router and put the hub into modem mode. I know it defeats the point of "upgrading" to the latest "Super" Hub but the only other thing to do is contact customer support and see what they say.
0 Kudos
Reply
  • 9.96K
  • 290
  • 623
Forum Team
Forum Team
2,905 Views
Message 8 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Hey there ridavey,

Thanks for getting in touch and welcome to the community Smiley Very Happy

Sorry to hear about the troubles with your wireless connection. I wonder if you've tried all of the wireless channels yet? Sam has posted instructions on how to do this in her post above. If this doesn't help, let us know and we will continue to investigate.

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
Highlighted
  • 13
  • 0
  • 2
Mw0hmv
On our wavelength
2,346 Views
Message 9 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Has this been resolved ? I have the same problem and I'm pulling my hair out !
0 Kudos
Reply
  • 23
  • 0
  • 1
A_Sweaty_Wombat
Tuning in
2,342 Views
Message 10 of 52
Flag for a moderator

Re: SuperHub 3 slow Wi-Fi

Welcome to the club. I am now bald.

Unfortunately, I have not found a solution just yet. The copy & paste answers from staff shed no light nor do they help.

I will definitely update this page if/when I find something.
0 Kudos
Reply