Menu
Reply
  • 14
  • 0
  • 0
oscarandjo
Tuning in
874 Views
Message 1 of 14
Flag for a moderator

SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

I had my SuperHub 2 replaced recently after it broke due to a power surge taking it out (as well as £50 worth of switches connected to it!) with a SuperHub 3.

I'm by no means a technophobe, I study Computer Science and generally think I'm quite good with this sort of stuff. My SuperHub 3 has been a nightmare.

I put my SuperHub 3 into the same setup I had my SuperHub 2 and everything worked fine at first, but after my devices are connected for about 30 minutes I notice the WiFi stops working. On my Android phone in settings for the WiFi network it says "Connected, no Internet", and after this I can't load any internet pages and also can't communicate with any other devices on the local network.

The odd part is that this isn't an internet outage, as devices connected to the Router over Ethernet work fine. It seems to be isolated to the WiFi of the router.

I called Virgin Media today and the support agent got through two lists of (painfully basic) diagnostics and said that it was a very unusual issue before ending the call with no resolution after being on the phone for about an hour.

I'm curious to hear if others have had the same issue, but quite frankly, I think this SuperHub 3 has a faulty WiFi module. I would like a replacement SuperHub 3 as I'm certain it's faulty.

0 Kudos
Reply
  • 2
  • 0
  • 0
neilapudney
Joining in
851 Views
Message 2 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Hi

We have the same issue. Less than a week in to our contract we have had over 24hrs of no Tv Internet or phone so far and the signal drops out. I have coceres the house in TP link extenders but bow I just have brilliant signal but no speed and lost connections constantly.
0 Kudos
Reply
  • 14
  • 0
  • 0
oscarandjo
Tuning in
848 Views
Message 3 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

If your TV and Internet drops out it must be a line issue, my complaint is with the SuperHub 3 not the line. I think you actually have a different issue, which fortunately for you, is one that might be fixable by a technician Smiley Happy

Once you get that line issue solved I'm sure your internet will be better, good luck!

0 Kudos
Reply
  • 9.96K
  • 290
  • 622
Forum Team
Forum Team
808 Views
Message 4 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Hi oscarandjo,

 

Thanks for posting Smiley Very Happy

 

I'm sorry that you're having problem with your new Hub 3, it sounds frustrating.

 

It might be an option to revert back to a Superhub 2 if you left it was more suited to your set-up.

 

Let's continue to discuss this via PM (purple envelope, top right).

 

Speak with you very soon,

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
  • 7
  • 0
  • 1
sheroo
Tuning in
705 Views
Message 5 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Hi, 

Did you ever get this fixed? I'm having the exact same issue with both my phones. I know the phones work fine as I've tested them at a family members house elsewhere with the older router.

0 Kudos
Reply
  • 7
  • 0
  • 2
derrylad
Tuning in
675 Views
Message 6 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Hi,

Can you get in touch with me too?  I'm having the exact same issue with these so called "SUPER"hub3 routers!

The WiFi chip on these rebranded netgear Superhub3 routers(with the half decent stuff stripped out) is shocking poor!!  After 2 months of grappling with this, I've isolated the problem to the 2.4Ghz wireless chip.  Essentially, when I disable 2.4G signal the connectivity stablises and life is good with near 200Mb speeds.... problem is, most of my kids devices and media devices, which are over 2 years old, cant connect at 5Ghz signal!

Just sort it out Virgin!  Recall all these Superhub3 devices and replace with something that just works!   I'm left with 2 options... Spend circa £200 on a decent WiFi device/s, or get Virginmedia to replace their faulty device!

 

0 Kudos
Reply
  • 8.99K
  • 756
  • 1.87K
Superuser
Superuser
668 Views
Message 7 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

The Hub 3s are made by Arris, not Netgear and I am not sure how you would strip anything out of them.

If the wireless is fine on the 5Ghz band then it looks like interfence on the narrow 2.4Ghz band is playing a major part.

Changing the wireless channel the 2.4Ghz radio is broadcasting on can help. This forum is littered with further adviice on this.

0 Kudos
Reply
  • 24
  • 0
  • 1
DeanH67
Tuning in
663 Views
Message 8 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

I have had this issue since our 'upgrade' a month ago, numerous phonecalls and tech visits have failed to sort it - all I keep getting told is to buy a router and use the Hub 3 as Modem - not ideal really.

in my last call this week i did ask if i could revert back to the hub 2 which we had no problems with for many years...

 

  • 7
  • 0
  • 2
derrylad
Tuning in
663 Views
Message 9 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Fair enough on the brand. The older hubs were netgear, but why is there no issue when I use my old BT hub5 and TP Link cheapo plug as access points? 2.4G works beautifully on those?

Btw... Changing channels solves nothing.
0 Kudos
Reply
  • 7
  • 0
  • 2
derrylad
Tuning in
661 Views
Message 10 of 14
Flag for a moderator

Re: SuperHub 3 WiFi dropouts "Connected, no Internet" meanwhile Ethernet works fine!

Hi Dean,

I'm at the point where I just give up on VM WiFi. It's​ sickening that we have to purchase additional kit to make things work properly! Customer service at VM is removed

[MOD EDIT: Inappropriate language removed, please review the Forum Guidelines]

0 Kudos
Reply