Menu
Reply
  • 8
  • 0
  • 0
Varchola
Joining in
429 Views
Message 1 of 13
Flag for a moderator

Link speed auto-negotiation

Hi,

Spent an hour on the phone trying to get this sorted with the Virgin support but got absolutely nowhere so I'm hoping someone here will be able to provide some advice.

 

Recently I've had my package upgraded and with it I've received a SuperHub 3. The Ethernet connection kept dropping for about 30 seconds every 5 minutes. Suspecting a power issue on the SuperHub I've called the support team and had the unit replaced.

Issue kept persisting however so I went on to do some troubleshooting. First I looked at the link speed setting which was set to auto-negotiation by default. My connection was down at that point and I've set it manually to 100BASE. This brought the connection straight back up. I then switched it to 1000BASE and this brought the connection back down. Once I set it back to 100BASE it came back up and now it 'only' drops for about 3-4 seconds every 5 minutes. Unfortunately some services are still unable to handle this brief drop of connection.

It seems to be that the link-speed setting is what's causing this. The SuperHub wants to bring the connection up to 1Gb/s but for whatever reason this does not work. I know I can't change this setting on the device as a customer but I'm pretty confident that the setting is there. Does anyone have an idea on how I could access advanced features on the device?

 

Thank you,

Viktor Varchola

0 Kudos
Reply
  • 8.99K
  • 756
  • 1.87K
Superuser
Superuser
426 Views
Message 2 of 13
Flag for a moderator

Re: Link speed auto-negotiation

Try setting your ethernet adapter to autonegotiation. This is what the hub's ports are set to so setting your device to anything else will create a duplex mismatch.

The brief connection drops are more than likely due to the local VM circuit and not your equipment.

Posting some basic diagnostic info may help.

Navigate to the hub's GUI using http://192.168.100.1
Don't log in, click the Router Status button in the top right of the screen.
Copy \ Paste the Downstream, Upstream, and Network Logs.

Don't worry about the formatting, but do obscure personal information like your WAN IP address.

 

0 Kudos
Reply
  • 8
  • 0
  • 0
Varchola
Joining in
423 Views
Message 3 of 13
Flag for a moderator

Re: Link speed auto-negotiation

It's not an issue with the WAN. Works fine on WiFi. The devices on ethernet drop connection though, with 'network cable unplugged' message.

And I have set it to duplex...if the SuperHub is set to auto-negotiate and my side is set to 100BASE duplex then that should negate the need for negotiation and keep the device at 100BASE duplex.
0 Kudos
Reply
  • 8
  • 0
  • 0
Varchola
Joining in
422 Views
Message 4 of 13
Flag for a moderator

Re: Link speed auto-negotiation

The network logs unfortunately only show the WAN events, nothing on the LAN. The event viewer on the computers does show the LAN connection being dropped over and over.

0 Kudos
Reply
  • 8.99K
  • 756
  • 1.87K
Superuser
Superuser
398 Views
Message 5 of 13
Flag for a moderator

Re: Link speed auto-negotiation

Varchola wrote:
It's not an issue with the WAN. Works fine on WiFi. The devices on ethernet drop connection though, with 'network cable unplugged' message.

And I have set it to duplex...if the SuperHub is set to auto-negotiate and my side is set to 100BASE duplex then that should negate the need for negotiation and keep the device at 100BASE duplex.

What is 100BASE duplex? 

No, If you had read the link I included,  "When a device set to autonegotiation is connected to a device that is not using autonegotiation, the autonegotiation process fails", this causes the port set to autonegotiation to fail back to half duplex, whilst the port set to 100 or 1000 speeds will be locked at full duplex assuming you have not used the half duplex settings. Thus causing a duplex mismatch. It is not possible to change the port speed \ duplex on the Hub.

As you have now stated it is a LAN not a WAN problem, I would suspect the ethernet cable, might be worth trying another one.  It would also be worth checking the ethernet adapters are up to date according to the ethernet adapter's manufacturer's website.

If that fails it might be worth doing a factory reset on the hub just to eliminate to eliminate a firmware glitch.

If all fails then it may be a hardware fault with the hub, very unlikely as it has happened on two hubs.

 

  • 8
  • 0
  • 0
Varchola
Joining in
394 Views
Message 6 of 13
Flag for a moderator

Re: Link speed auto-negotiation

If it's set to auto-negotiation the issue worsens.As mentioned in my post I imagine the device is setting the speed to 1Gb/s and that is what causes the connection to drop. When it's manually set to 100 the drops are much less severed. If the hub was also set to this speed I'd imagine the drops would be eliminated.

The cable has been fluke tested with no issues. It's a Cat6 cable so I don't imagine that to be the fault. Neither should it be a firmware/hardware fault with the hub. There are no settings changed on the device other than the SSID name and password and I've had 2 units with the exact same issue.

0 Kudos
Reply
  • 14
  • 0
  • 1
oldfield04
Tuning in
358 Views
Message 7 of 13
Flag for a moderator

Re: Link speed auto-negotiation

have been having the same problem with the superhub 3. It was working fine until 4 days ago. After much reading up and testing I solved my issue by, like a previous answer says, changing auto negotiating to half duplex 100mbs. Tested streaming the xbox one and playing a game on the laptop. All worked without issue or any drop in connection. It did, however, seem to slow my speeds by half so am guessing this is because of the setting.

So it seems the superhub is dealing with speeds that are too quick for some devices, certainly for my laptop when wired.

I telephone VM broadband services who reset my superhub and told me everything was fine - even when I was watching my pc tell me that it was still connecting/reconnecting to the hub ..... fed up of them to be honest. It's just a way to spend an hour and get wound up lol.

So I have windows 10 and this is what I did: 

Right click on the windows logo and then open network adapters - right click on the adapter (mine is Realtek PCle Family controller)

Then click on PROPERTIES - then ADVANCED tab - scroll down and then click on SPEED & DUPLEX - 

In the drop down menu under VALUE find and click on the 100Mbps HALF DUPLEX and then click OK at the bottom of the box.

PC will disconnect and then reconnect but then with me held connection with no drops at all. However, like I said above it seems to cause my speed to half but become a lot more stable.

I hope this helps someone, I'm not tec savvie but dogged if nothing else. I will be ringing VM again next week to ask advice once again and also why this seems to have recently been happening.

0 Kudos
Reply
  • 8
  • 0
  • 0
Varchola
Joining in
335 Views
Message 8 of 13
Flag for a moderator

Re: Link speed auto-negotiation

Hi,

 

So we have a workaround but not a resolution. Seems that nobody from Virgin wants to touch this...

0 Kudos
Reply
  • 14
  • 0
  • 1
oldfield04
Tuning in
321 Views
Message 9 of 13
Flag for a moderator

Re: Link speed auto-negotiation

I spoke to someone today on the 2nd line broadband issues team.

If the problem with the connectivity is when in modem mode then they are aware of this issue and are ongoing in trying to resolve through updates with new software patches. However, it seems that my issue is different as I am using the router in full mode. So they say it is my router that has the issue and have agreed to send me a new one. I have tried PC on a Sky network and it worked fine connected via ethernet.

So we shall see what the new router has to offer me....

0 Kudos
Reply
  • 8
  • 0
  • 0
Varchola
Joining in
313 Views
Message 10 of 13
Flag for a moderator

Re: Link speed auto-negotiation

I have my device in router mode, they have sent me a new one. Has not change a thing.

 

Problem most likely is as I've mentioned. Auto negotiation. The new router has the same setting as the old one, hence nothing changes.

0 Kudos
Reply