Menu
Reply
  • 27
  • 0
  • 1
emailwoes
Tuning in
169 Views
Message 1 of 6
Flag for a moderator

Jumbo frames causing superhub 2ac to disconnect internet

I have a Virgin Media Superhub 2AC.

On 16/01/17 I noticed visits to certain websites would kill my internet connection.  My router was still OK, it still had the WAN IP address from Virgin Media but I could not get out to the internet from any device on my network.  I could not ping the Virgin Media DNS server, all external access was lost and a SH reboot was required.  This was most commonly found on Ebay, if I complete a search and simply scroll up and down the results a few times the connection would drop.  This happened on all of my Windows 7 PCs (I'm not using W10 at all, its garbage).  I noticed it too on the VW website.

Chrome, IE and Firefox all yielded the same results.  Determined to find the cause I started disconnecting devices one by one and re-testing, I removed my powerline, Sky Q box, printer, switch, everything - I ended up with just one laptop connected to an Ethernet port on my router.  I tried every possible option on my router with the firewall settings to rule that out.  I even factory reset it.

Next, I noticed that the same PC did not have this problem on wifi, just wired connection.  I ruled out NIC issues given multiple PCs all caused this problem.  Since turning off jumbo frames at Windows level, the problem has gone away.

I have my home network set to 1GB/FD using 9k jumbo frames.  Why I do this or whether it makes any difference to anything is not up for debate here, the fact is that's what I do and I want it that way.  I use a HP ProCurve managed switch that is set to 1GB/FD with jumbo frame support enabled.  All my PCs and NAS etc are all set to 9k jumbo frames, 1GB/FD.  This all works just the way I want it to, so now I need to know why using jumbo frames has suddenly started killing my internet connection.

Either something has changed with my router or the way certain websites handle traffic sent in jumbo frames is killing it...I just don't get it.  I see other folk having this with the SH2, but not the AC.  Maybe it's just broken.

Any ideas anyone?

0 Kudos
Reply
  • 39
  • 2
  • 6
gavinh
On our wavelength
157 Views
Message 2 of 6
Flag for a moderator

Re: Jumbo frames causing superhub 2ac to disconnect internet

It certainly does sound similar to my issue (http://community.virginmedia.com/t5/Networking-and-wireless/Jumbo-Frames-causing-Superhub-2ac-to-dro...), but my Jumbo frame issue was resolved by upgrading from the superhub 2 to the 2ac, where you are saying you still have the problem with the 2ac!

Are you 100% certain you have the 2ac, as I thought that is what I had initially until I realised it wasn't!! They look practically the same.

You could try reducing your jumbo frame size down to see if that makes any difference?

0 Kudos
Reply
  • 27
  • 0
  • 1
emailwoes
Tuning in
152 Views
Message 3 of 6
Flag for a moderator

Re: Jumbo frames causing superhub 2ac to disconnect internet

Yes I have the 2AC for sure, I had to send 3 x SH2 and 1 x SH3 back before they finally sent me this one!  I'll try 4K JF when I don't need my connection and report back.  My welcome screen states: "Welcome to your Virgin Media Super Hub 2ac"

0 Kudos
Reply
  • 27
  • 0
  • 1
emailwoes
Tuning in
144 Views
Message 4 of 6
Flag for a moderator

Re: Jumbo frames causing superhub 2ac to disconnect internet

I just tried it on 4K jumbo frames and it was fine, set to 9 and it died.  That PC only has the 4/9k option and I can't be bothered to dig out a server NIC that has the options between 4-9k to find the exact failure point.  The point is 9k was working just fine up until two days ago Smiley Sad

0 Kudos
Reply
  • 39
  • 2
  • 6
gavinh
On our wavelength
117 Views
Message 5 of 6
Flag for a moderator

Re: Jumbo frames causing superhub 2ac to disconnect internet

I have just set my NIC (Intel(R) Ethernet Connection I217-LM) to 9K Jumbo frames, no other network device is active, browsed/searched EBAY and the Superhub 2AC remained stable.  I downloaded several large files from various WWW sites and again it remained stable. 

You said this used to work fine before, I guess the million dollar question is what has changed since? I know from bitter experience trying to get anybody from VirginMedia tech support to listen is virtually impossible.  For your own health and well being, I'd suggest just sticking at 4K jumbo frames, you won't see much of a performance hit, if any, vs 9K, unless of course you are running state of the art server kit with high-end corporate networks?

0 Kudos
Reply
  • 27
  • 0
  • 1
emailwoes
Tuning in
109 Views
Message 6 of 6
Flag for a moderator

Re: Jumbo frames causing superhub 2ac to disconnect internet

Thanks for trying that.  I've changed nothing at all Smiley Sad.  The NICs I can re-create this on are:

Intel 82579V
Intel I217-LM
Atheros AR8114
Broadcom BC5709C
HP NC331T (probably Intel)

It's just so odd that it is only on certain websites.  It's probably struggling to load the colossal amounts of side-screen ads ebay comes with these days.

I guess I will have to drop to 4k, would love to know what's causing it though.

 

0 Kudos
Reply