Menu
Reply
  • 9
  • 0
  • 1
Uralowl1
Tuning in
85 Views
Message 1 of 3
Flag for a moderator

Issues with Superhub 3 and Windows 8

Hi there,

So I finally got my old superhub 1 replaced with a superhub 3 yesterday. One issue I've encountered though is that my windows 8 laptop doesn't seem to like the new hub all that much. Often when first turning it on, within the first 2-3 minutes after being switched on, it will lose internet, but still be connected to the hub.

It will simply come up with a yellow caution sign on the network icon in the bottom right corner of the screen and say "limited", but there'll be no connection at all. It's easy enough to fix by simply disconnecting from the network and reconnecting, but it will sometimes happen again at random points, if the laptop has been on for 30 minutes to an hour or more.

When this happens, I check my other devices, and the internet will still be working perfectly fine on them, so it seems this problem is specific to my Windows 8 laptop, at least so far. This never used to happen with the old superhub, so I can only assume it's an issue that's been created with the SH3.

Any suggestions?

0 Kudos
Reply
  • 9.02K
  • 760
  • 1.88K
Superuser
Superuser
69 Views
Message 2 of 3
Flag for a moderator

Re: Issues with Superhub 3 and Windows 8

I would check the wifi card drivers are up to date according to the wifi card's manufacturer's website. (Do not rely on Windows Update).

 

0 Kudos
Reply
  • 10.04K
  • 294
  • 626
Forum Team
Forum Team
47 Views
Message 3 of 3
Flag for a moderator

Re: Issues with Superhub 3 and Windows 8

Hello Uralowl1,

 

Thanks for getting in touch, hope you're well Smiley Happy

 

Sorry to hear about the problems you're having with your connection.

 

Have you had any luck following griffin's advice?

 

Please get back to us to we can investigate further.

Take care.

Heather_J

Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply