Menu
Reply
  • 2
  • 0
  • 0
ChristianK
Joining in
6,280 Views
Message 1 of 30
Flag for a moderator

Hub 3.0 and Chromecast

Hi all, hope someone can help with this. I have had virgin installed over the weekend and have broadband with the HUB 3.0 router. I am having trouble with GEN1 Chromecast devices using the router. I have run through the setup of the devices and can see the Chromecast is in connected devices on the router but any phone or computer with the chromecast apps are unable to see the devices after setup. The GEN1 devices connect to the 2.4GHZ wireless and the phone and computer I am attempting setup with are connected to the 5GHZ. I have a GEN2 device that is dual banded and that connected and completed setup fine. I have tried to disable the 5GHz wireless signal so everything connects on 2.4GHZ and this makes no difference and even then prevents the GEN2 from working as well. I have ensured upnp is enabled and I can't find an option for multicast.

I am down to 2 options reall if i can't resolve. Buy another GEN2 or put the router in modem mode and use an alternative router.

 

Hope someone can offer any ideas? Cheers

Tags (1)
0 Kudos
Reply
  • 10.92K
  • 237
  • 2.01K
Superuser
Superuser
6,224 Views
Message 2 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

See > Chromecast-not-working-with-Hub3-0 <

Regards Tony
"Life is a Binary Inspired Turing Computed Hologram"(don't PM or @Mention me - in case ignoring you offends)
0 Kudos
Reply
  • 2
  • 0
  • 0
marx1
Joining in
5,856 Views
Message 3 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

I to have the same problem with chromecast version 1 shown as logged on to the router at 2.4Ghz, but still unable to use any supporting Apps.

Really love using the chromecast, just want to know if version 2 is trouble free...

0 Kudos
Reply
  • 5.26K
  • 230
  • 467
Forum Team
Forum Team
5,802 Views
Message 4 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Hi marx1,

 

Welcome to the community and thanks for posting your concerns.

 

I can see you've also posted here and had a reply from Shelke.

 

Thanks


Rich
Forum Team
0 Kudos
Reply
  • 5
  • 0
  • 0
tonyjwheeler
Tuning in
5,337 Views
Message 5 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

I had Virgin Internet installed today and cannot connect my Chromecast 2 to this new version 3 hub.  I've tried many of the ideas here including the use of the IOS (IPad) Chromecast app.  Nothing worked.  Interestingly, only the IOS app asked me to confirm my country (I'm using a US sourced CC2).  I'll call support a see what they say - hopefully I'll get a version 2 (working) hub till they fix this with a firmware update.

Tags (3)
0 Kudos
Reply
  • 12.48K
  • 353
  • 1.45K
Forum Team
Forum Team
5,288 Views
Message 6 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Hi tonyjwheeler,

Welcome to VM, always nice to have a new customer to offer our support to Smiley Happy

Impressed too that you've discovered our Forum so quickly too, I hope we don't disappoint.

Anyhow, with regards to the issues you've reported our trials didn't highlight any defects with Chromecast v2 and Hub 3. 

We are aware of the difficulties with CCv1, and yes, we'll soon deploy firmware that will resolve that. But your current CC should work fine - if it doesn't then it's highly unlikely that either the firmware or an older Hub model will help.

However, I shan't totally rule out a new Hub as it is possible that your current Hub is faulty. But I would like you to try a few things first please:

If none of the above helps, please post an update on here and I'll get your Hub replaced.

Thanks Smiley Happy

 

 


Jen
Forum Team



0 Kudos
Reply
  • 37
  • 0
  • 1
stunley
Tuning in
5,266 Views
Message 7 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Hi Jen. I have also had no luck connecting the Superhub 3.0 and either the first gen' Chromecast and now the Chromecast 2 - I took it (CC2) to my neighbour's house and it connected straight away (BT Infinity) so the CC is working.

Previously I had the older Superhub 2.0 and the first gen' Chromecast and everything worked fine.

Can I get a Superhub 2 delivered please? Also, will the older superhub limit the speed of the 200mb connection?

  • 12.48K
  • 353
  • 1.45K
Forum Team
Forum Team
5,259 Views
Message 8 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Hi stunley,

Apologies that you too are facing this difficulty. I honestly don't understand why CCv2 isn't working for you or the OP. 

Have you attempted the suggestions offered in my previous post?

 


Jen
Forum Team



0 Kudos
Reply
  • 5
  • 0
  • 0
tonyjwheeler
Tuning in
5,242 Views
Message 9 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Jen,

I am surprised that you think the CCv2 works with your latest version 3 router.  Others here also report the very same failuer to connect issue.  I had already completely reset the router and the CC.  In fact the CC was a brand new one.

In any case I reset both again and it still unfortunately cannot connect.  I did try the other advice (manually setting the network name and using WPA) but that also fails.  I'm not sure, however, how setting WPA can work if the router is trying to use WPA2 (but maybe it can do so) - in any case sorry but nothing worked.

I also have a Nest Thermostat for my home (not fitted) and I understand that also fails on this router so I'm delaying that fitting as your router appears not to support that either (interestingly both the Nest and the CC are both Google products - are they perhaps using a network capability that you do not, yet, fully support?).

I spoke to the Virgin support call centre and, after quoting this discussion, have been promised the previous version of the router (ver 2) by post.  Hopefully that will work and I'll report back here.

If you are testing another router firmware I'd be happy to help Jen.

Thanks for your help.

Tony

 

 

0 Kudos
Reply
  • 12.48K
  • 353
  • 1.45K
Forum Team
Forum Team
5,095 Views
Message 10 of 30
Flag for a moderator

Re: Hub 3.0 and Chromecast

Hi tonyjwheeler,

 

Aww sorry that you also have a Nest thermostat to contend with.  This incompatibility is on the defects list for inclusion in a future firmware upgrade but is not addressed in the pending f/w deployment (at least as things stand now, I'll let you know if that changes).

 

Obviously there's no need for me to send a replacement as you've already called in to arrange this. But please ignore any requests to return the Hub 3, as we can get that reactivated for you as soon as the f/w is imminent.

 

Keep us updated Smiley Happy


Jen
Forum Team



0 Kudos
Reply