Menu
Reply
  • 7
  • 0
  • 0
Bloodknok70
Joining in
263 Views
Message 1 of 12
Flag for a moderator

FTP Upload Problems - Constant Timeouts - different programmes

I am getting constant 'timing out' issues when trying to upload files to an ftp server through my Virgin Broadband for the last two to three months, whereas previously for the last FIVE years or more, I had no such problems.

I am experiencing this problem on TWO separate programmes, Rapidweaver and Freeway 7, when trying to upload through Virgin Broadband.

I have isolated the issue to the broadband I think because:

  • This is not programme specific - it's happened using Rapidweaver, Freeway 7 and an ftp client app - three different programmes trying to upload via ftp, same issue
  • I've checked with my host, and there are NO ISSUES with the hosting - my hosting company is able to upload files easily to my host servers
  • I have asked someone independently to load files up to my server using ftp, and they've had no issues doing it, without problems at all
  • I've managed on a couple of occasions to upload the most basic html files, but anything involving a graphic file is timing out, suggesting that there's a capacity issue or somethings are being blocked?

The only conclusion I can draw is that there is an issue with Virgin Media and uploading files via ftp through broadbac, that has not been an issue before but which has become one.

Has there been any change in my system, or settings, that mean .ftp servers are blocked? Are there any settings I can change which might account for this issue?

I've put the full breakdown of the scenario below - would appreciate any assistance, as am tearing my hair out.

________

Background on Freeway 7.
I had built a site1 using Freeway 7 by Softpress. It ran fine for years. But, when Freeway 7 was no longer supported, I chose to purchase Rapidweaver 7 instead to build a new version of the site.

Problem encountered
My site had lots of images and graphics in it, embedded video, Exhibio galleries etc. It worked flawlessly on uploading to my host site.

Then, about two months ago, on my iMac I - inadvertently - relocated all of the stored images I'd used on my Freeway 7 website into a new location on my iMac, in the same drive. Then, when I next came to upload something through Freeway 7, that's when I started getting "timeout" messages.

I thought it might be something to do with my server so on my server file manager I deleted all the html files that there on there (which I realise wasn't a sensible thing, now), in the hope that uploading everything new again might solve the problem. But, I couldn't upload anything from my previous site through the ftp server. I was left without a website.

Where previously images, Exhibio galleries etc had loaded up without problem, I somehow think that since moving this folder of stored images, nothing loaded up. If I tried to add an Exhibio gallery - that had worked previously - or a simple jpeg image to my site, nothing now uploads.

So, using Freeway 7, I rebuilt a basic site from scratch, using the same images (that were stored in a different file location on my computer). However, Freeway 7 would now always time out when uploading larger images and any Exhibio files.

Switch to Rapidweaver
I couldn't work out the problem, but I managed to somehow get a vanilla version of my website to upload onto my server using Freeway 7. So, I switched to Rapidweaver and built a very basic version of a site again, using images stored on my computer.

I built it and tested it on Safari, and it all worked fine. I had only added a couple of basic images to it. But when I went to publish it, it always timed out after about 10-15 of the 120 files were uploaded. Always getting the same message of 'timeout'.

I checked with Brian at RealMac, and sent him my Rapidweaver Project to upload to my server, and he said he could do so without any problems. I've just tried again today, and again, on a simple two-page site, with no graphic images embedded, it just keeps timing out.

So, I'm stuck and at my wits end. CAN ANYONE OFFER ANY SOLUTIONS/IDEAS?. The facts are:

Timing out issues are experienced now on Rapidweaver and Freeway 7 - two separate programmes, same timing out issue

It seems to be linked - but I don't know why - to when I copied a whole bunch of image files from one folder into a new one on my system, and deleted the old one (I thought all the images were contained within the site folder, and weren't somehow 'linked' back to what's stored on my computer). Since that point, I've not been able to add or upload any images, and Exhibio Galleries I still have, which I know worked before, no longer upload on Freeway 7

Using Freeway, I have created the simplest of two-page sites, with no images in it, to try and see if the problem is something to do with image size - the timeouts always happen when the ftp reaches a new image file it hasn't uploaded - but even a vanilla site will no longer upload.

Since purchasing Rapidweaver, I have not been able to upload ANY pages. It seems like it's 'inherited' the problem I experienced with Freeway 7 - the timeouts. I can't see how this can be the case, which makes me think it's not an issue with Rapidweaver, but a setting on my iMac or something to do with my files which means they cannot be uploaded. But I've no idea what.

Brian from RealMac managed successfully to upload this basic site from an external computer onto my site host without any problems, making me think there's something I've changed on my computer that no longer allows either Rapidweaver or Freeway 7 to upload anything to my server and timeout.

I use hi-speed internet connection. I was asked if the issue might be my connection - I don't think so: I manage to upload large video files up to Dropbox, for example, with no problem. But a very basic html file on Rapidweaver it just timesout. There's nothing wrong with my server, as I've checked with my host company - they've managed to upload files to the site fine.

So, I'm stuck. Since experiencing the original problem with Freeway 7, I've encountered the fact that I can create a site on Rapidweaver fine, but just cannot upload it at all.

I've transferred the simple text site to an ftp uploading software app, and again, I get the timeout issue using an ftp client app, which again suggests the issue is on my iMac or in my uploading settings (on what?) or perhaps my security settings, maybe?

So, I'm stuck. I don't think it's Rapidweaver that's at issue, but the fact that it and Freeway 7 are constantly timing out on anything I try and upload - where the latter has previously done so without issue - suggests that it's something I'm doing.

I've since done a complete clean install of my computer and files using Time Machine, to try and get back to the way things were before, but I'm still experiencing this timeout issue.

What have I changed on my system that might cause this on Rapidweaver, Freeway 7 and an ftp client app - constant timing out on even basic html files, not even video or large images?

How can I resolve this, when even a clean restore of my system, and the Rapidweaver software re-installed, doesn't solve the problem.

Where should I be looking for problems that might unlock this timing out issues. Would really appreciate any help anyone can provide, as I'm at my wits end. I'm an experienced Mac user, and have mastered building a site on Rapidweaver, but am absolutely stumped by this uploading timing out issue.

 

0 Kudos
Reply
  • 9.86K
  • 322
  • 850
legacy1
Hero
256 Views
Message 2 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

0 Kudos
Reply
  • 7
  • 0
  • 0
Bloodknok70
Joining in
252 Views
Message 3 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

No, I've not done that yet. I don't have a modem cable available. 

My question is, for five years or more, I've been able upload from my Mac to my server via wireless, not problems and no timeouts. It's only been in the last two months something has changed.

I guess I can buy a modem cable and see what happens.

0 Kudos
Reply
  • 9.86K
  • 322
  • 850
legacy1
Hero
239 Views
Message 4 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes


Bloodknok70 wrote:

No, I've not done that yet. I don't have a modem cable available. 


Your mean a Ethernet cable?

 

 

0 Kudos
Reply
  • 7
  • 0
  • 0
Bloodknok70
Joining in
236 Views
Message 5 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

Yes, you're right. I've just purchased one of those, connected via the Ethernet port to the super hub, and changed mode as instructed in your post link. 

Again, nothing. Just tried to upload a website which, two months ago, uploaded fine. Now, as soon as it reaches trying to upload a simple .pdf file, it stalls, then I get the timeout message.

This upload has previously worked fine for five or more years. Now, nothing's uploading, either wirelessly or wired. And it's happening on separate programmes. 

Yet, I can upload big files wirelessly to Dropbox fine.

0 Kudos
Reply
  • 9.86K
  • 322
  • 850
legacy1
Hero
226 Views
Message 6 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

If you know the address or IP you can get tracetcp and run the following
http://simulatedsimian.github.io/tracetcp_download.html
tracetcp IP:21

Are you able to connect to other FTP sites fine?

0 Kudos
Reply
  • 7
  • 0
  • 0
Bloodknok70
Joining in
224 Views
Message 7 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

I'm using a Mac, this looks like a pc windows programme, no?

I have successfully connected to my host servers using Cyberduck fine, but when I try to export and upload the website I've created, it gets about 11 of 215 files in, normally on a small graphic file, and then times out.

0 Kudos
Reply
  • 9.86K
  • 322
  • 850
legacy1
Hero
219 Views
Message 8 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes


Bloodknok70 wrote:

I have successfully connected to my host servers using Cyberduck fine, but when I try to export and upload the website I've created, it gets about 11 of 215 files in, normally on a small graphic file, and then times out.


So now your saying you can connect to the FTP server?

Switch to modem mode and try uploading again.

 

0 Kudos
Reply
  • 7
  • 0
  • 0
Bloodknok70
Joining in
210 Views
Message 9 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

To be clear, I did switch to modem mode, using the Superhub as a modem, as indicated in the guidance link posted up here, but it was the same result as trying to upload via wireless. Simply timed out.

I have no problems with my broadband uploading massive video files to Dropbox, say, but a tiny little two-page website on Rapidweaver or on Freeway 7, which loaded up previously, will not upload. I must have changed something.

Are there any settings on the Superhub which might make uploading via ftp problematic?

0 Kudos
Reply
  • 9.86K
  • 322
  • 850
legacy1
Hero
198 Views
Message 10 of 12
Flag for a moderator

Re: FTP Upload Problems - Constant Timeouts - different programmes

Can you test uploading to another FTP server somewhere?

0 Kudos
Reply