Menu
Reply
  • 12
  • 0
  • 0
h4mza
Joining in
89 Views
Message 1 of 2
Flag for a moderator

Constant loss of speed and connection

For the past couple of months, I have noticed constant loss of connection and slow speeds even though I am sat right next to the router. My whole family has Apple devices and they keep asking for password when it's already saved and my password hasn't been changed at all so I don't get why it keeps asking for passwords and also I have to enter password multiple times because the phone show incorrect password when I have put correct password. I thought it was problem with Apple devices but now my Android phone is doing the same and this morning my moms laptop got disconnected and was not connecting. It showed yellow exclamation mark with limited or no internet connection. My internet upstairs in bedroom is no longer fast, it has slowed down very much that pages take forever to load and I often get disconnected. I am using superhub 2 and ever since I got it, I've never been happy with it. If I remember, I had asked a question on here long time ago with same problem but this time it has gotten worse. Can somebody help?

0 Kudos
Reply
  • 5.43K
  • 201
  • 324
Forum Team
Forum Team
40 Views
Message 2 of 2
Flag for a moderator

Re: Constant loss of speed and connection

Hello h4mza,

 

Thanks for posting and I'm sorry to learn you're experiencing slow speeds.

 

I would like to take a look into this for you but I will need to gain access to your account so if you click on the purple envelope at the top right of your screen you will see a message waiting for you requesting further details.

 

Talk to you soon

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply