Menu
Reply
  • 2
  • 0
  • 0
UrbanScot
Joining in
4,186 Views
Message 1 of 6
Flag for a moderator

Connection issues Belkin N300 single range wifi extender and new fast superhub

I am seeking some help...I was using a Belkin wifi extender with reasonable success to boost my signal using the old hub and linking into an apple airport.

ive just upgraded to the new super fast broadband with 5g and 2g, got rid of the Apple airport and reset my Belkin to setup again.

i understand that it only boosts the 2g signal but despite managing to connect it, it then drops the signal and is useless.  99% of the time it is searching for a signal and no one can access the Internet at all. Does anyone have any expertise or ideas to set this up effectively.

it is not a distance from modem issue as I've tried it in the same room as well.

 

0 Kudos
Reply
  • 5.32K
  • 169
  • 353
Moderator
Moderator
4,153 Views
Message 2 of 6
Flag for a moderator

Re: Connection issues Belkin N300 single range wifi extender and new fast superhub

Hi UrbanScot,

 

Welcome to the community Smiley Happy I'm sorry to hear that your Belkin extender is dropping the wireless connection with the new hub.  That does sound frustrating, I'd like to help if I can.

 

I just want to check, if you connect any devices directly to the hub via wifi, do they also drop?  Or is this behaviour exclusive to the Belkin extender?  If it is happening across multiple devices, do any of the lights on the hub change when the drops occur?  I've tested the hub and everything looks good when I'm testing, I don't see any problems that would explain the issues you're seeing.

 

If you could let me know a bit more info as per my questions above, I'll do what I can to help.

Kev

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 2
  • 0
  • 0
UrbanScot
Joining in
4,137 Views
Message 3 of 6
Flag for a moderator

Re: Connection issues Belkin N300 single range wifi extender and new fast superhub

Hi Kev,

Thanks for the welcome.  The hubs re single band wifi extenders that I plug in, they worked fine with the old router but the new superb keeps dropping the connection.  

Normal wifi connections to the superb are spot on - my laptop works fine next to it on 5g but the signal is too weak to go upstairs in the house.  I switched the WPA auto to WPA and managed to secure a connection when I rest and setup a new connection to the Belkin wifi extender however this worked until I moved the unit and once again back to square one (even when I moved it back or tried to reset it)! 

The lights on the hub seem fine, both flashing away, it just doesn't seem to communicate well with the Belkin wifi extenders and therefore doesn't boot my signal all over the house (imagine the complaints of the kids with the x-box upstairs!!)

I did consider putting the superb in modem mode and using an apple airport an then connecting the wifi extenders to the but I think I will then not get the 5g connection or speeds that I should be getting with the new improved superhub.

Does this help at all?

 

Thanks,

 

Peter

 

0 Kudos
Reply
  • 5.32K
  • 169
  • 353
Moderator
Moderator
4,113 Views
Message 4 of 6
Flag for a moderator

Re: Connection issues Belkin N300 single range wifi extender and new fast superhub

Hi Peter,

Thanks for getting back to us, that is helpful thanks. I just wanted to make sure the hub's wireless was performing normally before proceeding. 

I've had a look around and the literature I can find seems to suggest the Belkin N300 only supports 2.4 GHz, did you change the security settings for this band in particular? From what I can find online the extender has a light sequence to depict various states, can I ask what's happening with the light on the extender?

It might be worth setting up a guest network on the 2.4 GHz band to see if you can get the extender connected to that, though I'd recommend trying a few different security types on the 2.4 GHz network in the hub first.

Let me know how you get on.

Kev

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 1
  • 0
  • 1
debra213
Joining in
2,714 Views
Message 5 of 6
Flag for a moderator

Re: Connection issues Belkin N300 single range wifi extender and new fast superhub

I Think i Got This Fixed . First Reset Your Belkin Range Extender And Setup it again . i found this information online visit https://fixingblog.com/how-to-setup-or-reset-the-belkin-range-extender/ See If This Helps . 

Smiley HappyThanks Everybody 

  • 1
  • 0
  • 0
bedz1916
Joining in
1,925 Views
Message 6 of 6
Flag for a moderator

Re: Connection issues Belkin N300 single range wifi extender and new fast superhub

MY son uses a belkin router in his loft conversion however it keeps dropping my houses virginmedia broadband making my life misery having to resign in my laptop ipad phones ect tv for on demand,  this is very frustrating, when i go to my homepage when opening my own laptop downstairs it just shows a belkin homepage, and i dont even use one,

0 Kudos
Reply