Menu
Reply
  • 17
  • 0
  • 1
sirrahrc
Tuning in
1,060 Views
Message 1 of 18
Flag for a moderator

Connecting Superhub ro TP-Link Archer C2 router

I have just purchased a TP-Link Archer C2 router to connect to my VM Superhub.

I have set the Superhub to modem mode and if I then connect one computer directly to the first port on the hub, I can connect to the Internet.  However, when via the the C2 router, I cant connect.  

The C2 allows for a manual setup and I tried entering my WAN IP, I believe the Subnet Mask is 255.255.254.0, but I cant find the Default Gateway anywhere.  I have found the DNS servers: 194.168.4.100 and 194.168.8.100.

Can anyone help me with the DG please?

Thanks? 

0 Kudos
Reply
  • 9.02K
  • 760
  • 1.88K
Superuser
Superuser
1,048 Views
Message 2 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

Have you powercycled the hub and router.

Turn both off, power up the hub and wait a few mins untill a connection has been made. Then power up the router.

Subnet Mask should be 255.255.255.0

Whilst connected to the internet with the pc. Run a ipconfig /all command from Windows Command prompt. The default gateway should be listed. Should be something like 192.168.100.1

The router should not need a WAN IP address as the router should be set to get a WAN IP automatically from VM's servers.

0 Kudos
Reply
  • 17
  • 0
  • 1
sirrahrc
Tuning in
1,041 Views
Message 3 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

Thanks for your response.  Yes, I have powercycled both the Superhub and the router.

The subnet mask was 255.255.255.0 (typo in my last post).

I have started again by doing another powercycle of both units.  I can login to the TP-Link router and get to the Quick Setup page.  When I run the Autodetect wizard, this is what I get:

The router is failed to detect your internet connection type, the following are the most likely reasons:

  1. The router was not power cycled.

To solve this problem, please power cycle your router(turn if off and on) and wait 2 minutes to finish its initialization. If your router has a backup battery, please remove and reinsert its battery.

  1. The hardware connection is wrong.

To solve this problem, please double-check the internet port (blue port) is fully inserted with the Ethernet cable from your router or other network device.

  1. Your ISP (Internet Service provider) assigned a fixed (static) IP to you.

The router can not automatically detect such rare special network type, you need to enter the parameters manully.

Select one of the options below and click Next to preceed:

Now I will reboot my router, wait for 2 minutes and proceed; Usually this operation will resolve most of the issues.

I've rebooted the router before, now I will try to clone the MAC address from my original computer.

Yes, my ISP assigns me a fixed IP address.

 

This is exactly what happened last time and led me to enter the parameters manually.  So, I entered the information requested:

IP Address:          86.x.x.x (the WAN IP detected by www.whatismyip.com last time I was connected)

Subnet Mask:     255.255.255.0

Default Gateway:             192.168.12.1 (The internal address I have allocated to my router - and clearly not what is being asked for)

Primary DNS Server:        194.168.4.100    (DNS for VM found on Internet.  I have also used OpenDNS and Google DNS servers)

Secondary DNS Server:   194.168.8.100

 

The DG address is clearly incorrect as I need the WAN DG.  So, I guessed and used my IP address, but with a 1 at the end.  i.e. 86.x.x.1

 

This time the setup wizard completed (apparently) successfully.  However, no Internet.

I pinged the router on 192.168.12.1 – success

I pinged Microsoft.com, google.com, - timed out

I pinged 8.8.8.8 – timed out

I pinged 194.168.4.100 (VM’s DNS server) – timed out

I then set the setup wizard to Dynamic address and it fails on this too

So definitely not getting anything external.

This is an extract from the Status Page of the router:

WAN

MAC Address:**:**:**:**:**:**

IP Address:0.0.0.0(Dynamic IP)

Subnet Mask:0.0.0.0

Default Gateway:0.0.0.0

DNS Server:194.168.4.100 194.168.8.100

As you can see, it has failed to pick up any DHCP information from the VM Superhub when I set the connection type on the TP-Link as dynamic and the Superhub in Modem mode.

I don’t know why the auto detect doesn’t work and I have also posted a message on a TP-Link forum.

Also, the TP-Link isn’t picking up the configuration from VM when told it is a dynamic address and the manual settings are still in question and I can’t find anywhere the DG to use for VM.  

Could the VM Superhub be at fault here?

BTW, the only way I can read this forum and post replies is to re-set the Superhub.  I then need to put back to Modem mode to test out the settings

Any further suggestions would be most welcome.

0 Kudos
Reply
  • 17
  • 0
  • 1
sirrahrc
Tuning in
1,034 Views
Message 4 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

I have now resolved this.  The new router needed to clone the VM Superhub MAC address.

Not obvious.

Thanks for your help

0 Kudos
Reply
  • 103
  • 0
  • 4
purplemonkeyspa
On our wavelength
150 Views
Message 5 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

Old post but I'm having the same problem. Don't own a PC so I'm stuck TRYING to handle it all with my phone. Am I going to have to send this thing back?
0 Kudos
Reply
  • 9.88K
  • 323
  • 854
legacy1
Hero
143 Views
Message 6 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router


purplemonkeyspa wrote:
Old post but I'm having the same problem. Don't own a PC so I'm stuck TRYING to handle it all with my phone. Am I going to have to send this thing back?

What own model router do you have?

when in modem mode power off the hub for 2mins then with the TP-Link Archer C2 connected to the right port power on.

 

 

0 Kudos
Reply
  • 103
  • 0
  • 4
purplemonkeyspa
On our wavelength
137 Views
Message 7 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

c2 v3.0 ac900. Read reviews from people with Virgin singing it's praises.

When you say "the right port" I have from the C2'blue WAN port to the bottom port of the hub.

Every time I sign in to the router it says something about a WAN error.

Also it does give you the option to "set up internet connection" but after entering default username/password it pops up a message saying to enable cookies and won't go any further
0 Kudos
Reply
  • 9.88K
  • 323
  • 854
legacy1
Hero
128 Views
Message 8 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router


purplemonkeyspa wrote:
When you say "the right port" I have from the C2'blue WAN port to the bottom port of the hub.

Yes it should all work

 


purplemonkeyspa wrote:

Also it does give you the option to "set up internet connection" but after entering default username/password it pops up a message saying to enable cookies and won't go any further

 do not use the option for "entering default username/password" use DHCP

  

0 Kudos
Reply
  • 103
  • 0
  • 4
purplemonkeyspa
On our wavelength
127 Views
Message 9 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

Out of the box? Because it's not. Using the right cables (cat 5e even tried a cat 6) and they are securely fitted.
0 Kudos
Reply
  • 103
  • 0
  • 4
purplemonkeyspa
On our wavelength
122 Views
Message 10 of 18
Flag for a moderator

Re: Connecting Superhub ro TP-Link Archer C2 router

https://imgur.com/a/jH7E6
The errors I'm getting
0 Kudos
Reply