Menu
Reply
  • 11
  • 0
  • 0
Pphelix
Tuning in
62 Views
Message 1 of 4
Flag for a moderator

5G - 0.5 Mbps on my PC

As the title says, When I use 5G on my PC I get slow download speeds.

No EthernetNo Ethernet

Now that is with my wifi card - My wifi card supports 5G.

I have tried with Ethernet cable (Home plugs) and I still only peaked 25mbp/s with 5G ( I was downloading a game with ethernet and I was at around 800kbp/s and by the off-chance it would spike to 2mbp/s )

Just to be clear off what steps I've tried:

- Resetting router

- Factory resetting router

- Changed settings on my wifi dongle and default settings

- Changed 5G channels from auto and standalone values

 

I don't mind but I have a 100mbp/s package, I did a speedtest with my iPad ( 5G ) using the same website and the results are below:

speedtest.png

iPad was tested with same distance as my PC, even then I got poor results using Ethernet so.

This has only started to happen since around 10th December. I used to download games at around 10-12mbp/s.

I changed my wifi card so it only uses 2G and my download is accurate ( 50mbp/s for wireless )

I don't have time to mess around doing different ways of testing, I did it last time with my old thread due to a ping issue.. In the end it just fixed itself even though apparently no one was working in our area despite others experiencing the same issue.

 

0 Kudos
Reply
  • 21.63K
  • 775
  • 3.1K
Superuser
Superuser
58 Views
Message 2 of 4
Flag for a moderator

Re: 5G - 0.5 Mbps on my PC

Lets see....

You get full speeds on another device.
You get slow speeds on the same PC wired or wireless...


Answer connection is fine and its your PC.

Check for anything install that mgiht be slowing it down. as your connection is fine
0 Kudos
Reply
  • 11
  • 0
  • 0
Pphelix
Tuning in
54 Views
Message 3 of 4
Flag for a moderator

Re: 5G - 0.5 Mbps on my PC

Why would it only affect my 5G though? I'll have a look around but I don't recall downloading anything past the 10th.

0 Kudos
Reply
  • 9.01K
  • 758
  • 1.88K
Superuser
Superuser
39 Views
Message 4 of 4
Flag for a moderator

Re: 5G - 0.5 Mbps on my PC

You mentioned you are using a powerline adapter, has it got a wireless access point?  If so is it using the same SSID as the hub?

It could be that your PC is connecting to the hub whilst the IP is connecting to a stronger sugnal from the wireless powerline.

Otherwise I would look at the wireless adapter in the PC.

What nodel is it?

Have you updated the drivers from the adapter's manufacturer's website? (Do not rely on Windows update)

0 Kudos
Reply