Menu
Reply
  • 8
  • 0
  • 0
Frengineer
Joining in
262 Views
Message 1 of 11
Flag for a moderator

Trouble opening "Virgin my account" on galaxy s7 edge

It comes up with "Connection error"  as soon as I touch the icon.

Have tried uninstalling and reinstalling at least twice, does not help.

Frengineer

0 Kudos
Reply
  • 3.83K
  • 901
  • 1.7K
Superuser
Superuser
246 Views
Message 2 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Hi Frengineer,

 

are you using WiFi or mobile data?

You will first need to verify your account by accessing it over a mobile data connection.

 

AlexKid :-)

 If you want to say thanks > click 'Kudos'.
Answered your question? > click 'Mark as Helpful Answer' also.

0 Kudos
Reply
  • 8
  • 0
  • 0
Frengineer
Joining in
235 Views
Message 3 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Wifi is turned off as it asks.

Frengineer
0 Kudos
Reply
  • 287
  • 8
  • 25
Forum Team
Forum Team
213 Views
Message 4 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Hi Frengineer

 

Sorry to hear about your issues with the My Account app. There are a few suggestions I'd like to make.

 

  • Is your handset showing a 3G, H or H+ data connection at the top of your screen?

     

  • Is the time and date set correctly on the handset?

     

  • It’s worth noting that there are Virgin My Account apps for regions outside the UK as well and these will not work with UK mobile numbers. The icon for the UK app can be seen at this link.

Hope this helps but let me know if you have any further difficulty.

Dave


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 8
  • 0
  • 0
Frengineer
Joining in
204 Views
Message 5 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Time & date are OK.
No sign of any kind of connection.
In "Sim card status" - Signal strength is 107 dBm 3 asu - Mobile network type HSUPA
The icon is the same as your link.
Does this help?

Frengineer
0 Kudos
Reply
  • 287
  • 8
  • 25
Forum Team
Forum Team
191 Views
Message 6 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Hi Frengineer

 

Thanks for the reply. Are you able to access the internet on your other apps when WIFI is turned off on your handset?

 

Dave


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 8
  • 0
  • 0
Frengineer
Joining in
180 Views
Message 7 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Thanks to you I have now got it working.  It seems to be to do with "Mobile Data" &/or "Data Roaming".

Am I right in thinking that if I want to make sure it does not cost I have to keep MD on and DR off?  As I see it this means that MD only allows connection to my Virgin network,  if I use another network I would have to pay.

Hope I make sense.

 

Frengineer

 

 

0 Kudos
Reply
  • 287
  • 8
  • 25
Forum Team
Forum Team
174 Views
Message 8 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Hi Frengineer

 

I'm glad it helped. In answer to your question, yes you will need to ensure the Mobile data setting is enabled in order to get a data connection where WIFI is not available or not an option.

 

Data roaming does not need to be enabled unless you want to use a data connection outside the UK. Should you wish to use it at any point our site has a handy rundown of the costs involved.

 

Any questions let me know.

 

Dave

 

 


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 8
  • 0
  • 0
Frengineer
Joining in
171 Views
Message 9 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

Thank you very much.

Frengineer.

0 Kudos
Reply
  • 9
  • 0
  • 0
mr_pug
Joining in
170 Views
Message 10 of 11
Flag for a moderator

Re: Trouble opening "Virgin my account" on galaxy s7 edge

I also have this problem.  Since the app updated itself last week on my IPhone SE I have been unable to authorise it as I get a Connection Error screen stating "We're havening difficulty reaching our servers".  I have uninstalled and installed the app more than several times, reset the network settings and reset the phone several times. I have mobile data enabled and can use other apps on the internet.  Wifi is disabled when trying to connect. 

I was able to connect and see my account details before the update.

0 Kudos
Reply