Menu
Reply
  • 5
  • 0
  • 1
Druw
Tuning in
170 Views
Message 1 of 3
Flag for a moderator

Xbox One causing Strict NAT on PC?

Hello,

I've recently bought Rainbow Six Siege on PC and I always get a strict NAT type.
I've searched for guides on the internet on how to open it and only come up with one solution, which is to uncheck UPnP on my hub2, the re-enable it and reset the hub2.
When I come back online my NAT on Rainbow Six is now open. 
My problem is that when I turn on my Xbox One it seems to reset some setting or something in the hub2 because it instantly turns my NAT to strict on my PC.
I've tested this a few times now and its definitely only happening when I turn on my Xbox One. Both my Xbox One and PC are plugged in by Ethernet.

Does anyone have any solution to how I can stop this happening? Or why is happening?

Cheers

0 Kudos
Reply

Helpful Answers
  • 2.94K
  • 377
  • 929
Superuser
Superuser
317 Views
Message 2 of 3
Flag for a moderator
Helpful Answer

Re: Xbox One causing Strict NAT on PC?

Looking on the Ubisoft site it looks like Uplay on the PC and Xbox live use port 80.  My guess is that the infamously poor UPNP support in the VM hub is getting confused and not forwarding the data to port 80 on the PC because previously it was forwarding it to the Xbox One and thinks it still should.  Switching UPNP off and on probably wipes any settings it is remembering about the Xbox.

Similar issues are encountered if you try to run two consoles through a hub and one or both of them get strict NAT.  The best solution is to get a third party router that supports UPNP properly.  The only other solution I'm aware of is to put one device in the DMZ and setup port forwarding of the relevant game ports to the other device.  This second option is often hit and miss, so not guaranteed to work.

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Superhub 2 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.  


All Replies
  • 2.94K
  • 377
  • 929
Superuser
Superuser
318 Views
Message 2 of 3
Flag for a moderator
Helpful Answer

Re: Xbox One causing Strict NAT on PC?

Looking on the Ubisoft site it looks like Uplay on the PC and Xbox live use port 80.  My guess is that the infamously poor UPNP support in the VM hub is getting confused and not forwarding the data to port 80 on the PC because previously it was forwarding it to the Xbox One and thinks it still should.  Switching UPNP off and on probably wipes any settings it is remembering about the Xbox.

Similar issues are encountered if you try to run two consoles through a hub and one or both of them get strict NAT.  The best solution is to get a third party router that supports UPNP properly.  The only other solution I'm aware of is to put one device in the DMZ and setup port forwarding of the relevant game ports to the other device.  This second option is often hit and miss, so not guaranteed to work.

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Superhub 2 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.  

  • 5
  • 0
  • 1
Druw
Tuning in
154 Views
Message 3 of 3
Flag for a moderator

Re: Xbox One causing Strict NAT on PC?

Thanks for the reply

I've played about with the DMZ settings and had no luck, so I'll have a look for a good router.

Cheers