Menu
Reply
  • 1
  • 0
  • 0
undefinedyuuki
Joining in
207 Views
Message 1 of 2
Flag for a moderator

Unable to log into Overwatch (specifically) on launch

Hi there.

I appear to have run into a rather specific problem when trying to play a new game I recently bought called Overwatch. My internet is fine otherwise, but after going through a series of rigorous checks given by their support team, I'm left with the assumption that it is something on my end. Specifically, through running a pathping, find that when trying to connect to the server IP of Overwatch, that the connection fails to even leave my router.

Since I've tried power cycling my router, adding forwarding ports for the game on my router through a static IP, among other things, I'm honestly unsure as to where the problem lies, and was wondering if it was related to the ISP. 

If information is needed then let me know what I should post, but I was wondering if anyone could shed some light on this situation for me.

Regards,

Michael

P.S: For the record, I have NEVER gotten past the initial login screen, and so have NEVER properly connected to the game server, outside of connecting to the battle.net client just fine. I have all the required updates. 

0 Kudos
Reply
  • 9.02K
  • 295
  • 963
Forum Team
Forum Team
170 Views
Message 2 of 2
Flag for a moderator

Re: Unable to log into Overwatch (specifically) on launch

Hello undefinedyuuki

 

Welcome to our forum, I am sorry to hear of your problems connecting to Overwatch I wonder what is going on. You mentioned that you had already tried port forwarding, how about trying DMZ or for diagnostic purposes temporarily turning the hub firewall off or modem only mode Enabling and disabling modem mode on your Virgin Media router. The last option will also change you WAN IP so it is also a way to see if the site may be blocking your IP.

 

Please let us know how it goes.

 

Nicola

Virgin Media Forum Team
0 Kudos
Reply