Menu
Reply
  • 3
  • 0
  • 0
Luket88
Joining in
486 Views
Message 1 of 8
Flag for a moderator

Gaming performance is terrible

Hi,

Is there any reason why every time I play on Xbox live it's painfully slow and unresponsive?

I use a wired connection with a gaming router. I've port forwarded etc. I even bought a gaming monitor in the hope that might improve the issue, but unfortunately nothing.

It's honestly painful, and the only response I receive from Microsoft is that it's down to my isp.

Failing you actually providing a service that's adequate do you have any recommendations of isp's that provide a decent connection?
0 Kudos
Reply
  • 151
  • 1
  • 1
Lee2
On our wavelength
423 Views
Message 2 of 8
Flag for a moderator

Re: Gaming performance is terrible

I have same issue awful gaming experience especially in call of duty. People tell me BT are good for gaming
0 Kudos
Reply
Highlighted
  • 3
  • 0
  • 0
Luket88
Joining in
406 Views
Message 3 of 8
Flag for a moderator

Re: Gaming performance is terrible

From what I've been reading sky fibre is the best. Virgin apparently has latency issues and poor upload speeds, and they also have a problem with traffic at peak times which caps whatever internet package you have anyway.
0 Kudos
Reply
  • 151
  • 1
  • 1
Lee2
On our wavelength
385 Views
Message 4 of 8
Flag for a moderator

Re: Gaming performance is terrible

It's their superhubs, they have a latency like the superhub 3 I use.
My gaming is fine with little delay but the more matches I play the worse the latency gets (as worse as seconds behind other players) which is unbearable.
My guess is the superhubs are the issue, they're not stable enough, but hopefully they fix it but then again I've had this issue for 2 years
0 Kudos
Reply
  • 3
  • 0
  • 0
Luket88
Joining in
287 Views
Message 5 of 8
Flag for a moderator

SHOCK internet speeds not what I'm paying for

Surprise surprise! The quality of internet, speeds advertised and paid for etc is absolutely shocking.

The lag is ridiculous, it makes any game console unplayable.

I pay for 70+ download speeds.
I get 16mbps if I'm lucky.

Latency constantly on 136ms +
Packet loss always high.

I mean it was only yesterday they send an engineer out who says everything is fine...... well it's not.

No one I've encountered within this company actually understands what they are doing.

Why advertise a service which you clearly can't provide and won't acknowledge??

I would love for someone who actually has a clue within your company to look at the speeds I get and gameplay speeds you provide, it's embarrassing.

I mean you advertise a gaming broadband bundle however don't prioritise traffic during peak usage making it unplayable during peak hours
0 Kudos
Reply
  • 13.02K
  • 372
  • 1.06K
Moderator
Moderator
159 Views
Message 6 of 8
Flag for a moderator

Re: SHOCK internet speeds not what I'm paying for

Hi Luket88,

I've run a number of diagnostic checks on both your Hub and local network segment and both report back in good health, with pretty much zero peak time contention on both up and downstream channels, so the slow speeds and high latency is a bit of a mystery.

It would be helpful if you could drop the Hub into modem mode and try a direct connection to your device/console bypassing your router and let us know how the speeds/latency are looking.

Many thanks

 

Ralph_R
Forum Moderator

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


0 Kudos
Reply
  • 29
  • 0
  • 5
ShadowOfDeth69
Tuning in
149 Views
Message 7 of 8
Flag for a moderator

Re: SHOCK internet speeds not what I'm paying for

"...so the slow speeds and high latency is a bit of a mystery"

 

Are you serious? If this is the Hub 3 OP's talking about then you know full well there is no "mystery". 

0 Kudos
Reply
  • 514
  • 27
  • 121
deviousiphone
Rising star
144 Views
Message 8 of 8
Flag for a moderator

Re: SHOCK internet speeds not what I'm paying for

hmm yes the moderator dismissing the Hub 3's faults is the usual ploy, however even so with the latency being consistently above 100ms would indicate another problem, might be worth posting your upstream/downstream stats and the network log.
0 Kudos
Reply